tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: Ant Build Problem Undeploying Struts App from Tomcat
Date Wed, 02 Aug 2006 18:45:13 GMT
since 5.5.x is currently at .17, what don't you upgrade to that,
before you call deploy, make sure you call remove/undeploy
if the problem persists, post what is going wrong

Warren wrote:
> I am running Tomcat 5.5.3 on a Windows XP box. When I run my Ant build task
> to "undeploy" my webapp, it deletes everything except the struts.jar file.
> When I run my Ant "deploy" task it fails stating that an "Application
> already exists at path /...". I just updated to Tomcat 5.5.3 from 5.5.1.
> Everything worked correctly with 5.5.1, I just can't remember what I had
> set-up differently.
>
> <target name="install.only"
> description="Install application to servlet container">
>
> <deploy url="${manager.url}"
> username="${manager.username}"
> password="${manager.password}"
> path="${app.path}"
> localWar="file://${build.home}"/>
>
> </target>
>
> <target name="remove.only"
> description="Remove application on servlet container">
>
> <undeploy url="${manager.url}"
> username="${manager.username}"
> password="${manager.password}"
> path="${app.path}"/>
> </target>
>
>
> Thanks,
>
> Warren
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>   


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message