tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugeny N Dzhurinsky <b...@redwerk.com>
Subject mod_jk and Tomcat
Date Mon, 28 Aug 2006 13:31:42 GMT
Hello!

I'm trying to move Tomcat with it's web-applications from one server to
another, and I facing weird problem:

I copied working configurations for tomcat, mod_jk and httpd, but in
mod_jk.log I can see this:

[Mon Aug 28 21:35:39 2006]  [jk_uri_worker_map.c (459)]: Attempting to map URI '/user/'
[Mon Aug 28 21:35:39 2006]  [jk_uri_worker_map.c (483)]: jk_uri_worker_map_t::map_uri_to_worker,
Found a context match ajp13 -> /user/
[Mon Aug 28 21:35:39 2006]  [mod_jk.c (1689)]: Into handler r->proxyreq=0 r->handler=jakarta-servlet
r->notes=166127440 worker=ajp13
[Mon Aug 28 21:35:39 2006]  [jk_worker.c (90)]: Into wc_get_worker_for_name ajp13
[Mon Aug 28 21:35:39 2006]  [jk_worker.c (94)]: wc_get_worker_for_name, done found a worker
[Mon Aug 28 21:35:39 2006]  [mod_jk.c (472)]: agsp=80 agsn=www.linktiger.com hostn=www.linktiger.com
shostn=www.linktiger.com cbsport=0 sport=0 
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1741)]: Into jk_worker_t::get_endpoint
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1367)]: Into jk_endpoint_t::service
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (257)]: Into ajp_marshal_into_msgb
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (425)]: ajp_marshal_into_msgb - Done
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (136)]: Into jk_open_socket
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (143)]: jk_open_socket, try to connect socket =
12 to 127.0.0.1:8009
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (159)]: jk_open_socket, after connect ret = -1
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (188)]: jk_open_socket, connect() failed errno =
13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (720)]: Error connecting to tomcat. Tomcat is
probably not started or is listening on the wrong host/port (127.0.0.1:8009). Failed errno
= 13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1024)]: Error connecting to the Tomcat process.
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1468)]: sending request to tomcat failed in
send loop. err=0
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (136)]: Into jk_open_socket
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (143)]: jk_open_socket, try to connect socket =
12 to 127.0.0.1:8009
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (159)]: jk_open_socket, after connect ret = -1
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (188)]: jk_open_socket, connect() failed errno =
13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (720)]: Error connecting to tomcat. Tomcat is
probably not started or is listening on the wrong host/port (127.0.0.1:8009). Failed errno
= 13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1024)]: Error connecting to the Tomcat process.
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1468)]: sending request to tomcat failed in
send loop. err=1
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (136)]: Into jk_open_socket
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (143)]: jk_open_socket, try to connect socket =
12 to 127.0.0.1:8009
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (159)]: jk_open_socket, after connect ret = -1
[Mon Aug 28 21:35:39 2006]  [jk_connect.c (188)]: jk_open_socket, connect() failed errno =
13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (720)]: Error connecting to tomcat. Tomcat is
probably not started or is listening on the wrong host/port (127.0.0.1:8009). Failed errno
= 13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1024)]: Error connecting to the Tomcat process.
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1468)]: sending request to tomcat failed in
send loop. err=2
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1477)]: Error connecting to tomcat. Tomcat is
probably not started or is listening on the wrong port. worker=ajp13 failed errno = 13
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (1724)]: Into jk_endpoint_t::done, closing connection
0
[Mon Aug 28 21:35:39 2006]  [jk_ajp_common.c (567)]: In jk_endpoint_t::ajp_close_endpoint

and the thing is if I do 

telnet 127.0.0.1 8009 - it works fine!

How could that be?

here is my workers.properties file:

workers.tomcat_home=/home/user/tomcat
workers.java_home=/usr/java/jdk1.5.0_07
ps=/
worker.list=ajp13
worker.ajp13.port=8009
worker.ajp13.host=localhost
worker.ajp13.type=ajp13
worker.ajp13.lbfactor=1
worker.loadbalancer.type=lb
worker.loadbalancer.balanced_workers=ajp13
worker.inprocess.type=jni
worker.inprocess.class_path=$(workers.tomcat_home)$(ps)lib$(ps)tomcat.jar
worker.inprocess.cmd_line=start
worker.inprocess.jvm_lib=$(workers.java_home)$(ps)jre$(ps)lib$(ps)i386$(ps)server$(ps)libjvm.so
worker.inprocess.stdout=$(workers.tomcat_home)$(ps)logs$(ps)inprocess.stdout
worker.inprocess.stderr=$(workers.tomcat_home)$(ps)logs$(ps)inprocess.stderr

Could somebody please advice?

-- 
Eugene N Dzhurinsky

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message