tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Schönhaber <mailing-tomcat-u...@schoenhaber.de>
Subject Re: Tomcat 5.0/5.5 doesn't start using 'Configure Tomcat' dialog
Date Fri, 18 Aug 2006 11:12:45 GMT
Jan Andersson wrote:
> Trying to get Tomcat going with my app-under-development. Problem is that
> Tomcat refuses to start if I'm using the 'Configure Tomcat' dialog (i.e.
> Start->Programs->Apache Tomcat 5.5->Configure Tomcat). No message, it just
> silently fails. Logs are not touched at all.

Do you really click on the "Start" button on the "General" tab of the config 
dialog?

> Crazy thing here is that if I start Tomcat from the Windows services
> dialog (Start->Control Panel->Administrative Tools->Services->Apache
> Tomcat) it starts all right. Moreover, my app needs additions to the
> classpath and a flag to the JVM, and I add and apply these in the
> 'Configure Tomcat' dialog. Even though I start Tomcat from the Windows
> services dialog (which doesn't allow for tampering with classpath and JVM
> arguments), my app works correctly. And I'm completely sure it would NOT
> work at all without my classpath and JVM settings.

AFAIK, the changes you make using the config dialog are written to the 
registry. The Tomcat service runner reads them when the service is to be 
started - regardless whether you start the service using the "Start" button 
in the config dialog, the Tomcat monitor, the MMC, by using net start, sc or 
any other way that might exist to start a service.

> Have experienced this using Windows XP Prof with Tomcat 5.5 and Windows
> 2000 with Tomcat 5.0.

Tomcat 5.5.17 on XP Prof - works without problems for me.

Regards
  mks

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message