tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arunan Kannan" <arun...@gmail.com>
Subject Re: Tomcat shutdowns unexpectedly - Please help
Date Fri, 21 Jul 2006 07:28:35 GMT
Hi experts,

I have found the solution to this problem.
The problem is when we start a tomcat in solaris from a user shell (like
telnet) , then when the shell quits, the tomcat might get stopped.
The bourne shell gives the shutdown signal when the shell quits, to kill the
tomcat process.
 The solution to this problem is we should start/stop tomcat using C-shell.
Inside C-shell we need to start the tomcat.
At lost, after a good struggle to find this...it seems that it is working
(continously) fine now.

Please let me know if you have any comments.

Thanks all.
Thanks to Martin, Cosio, David, Alireza. Thanks to all experts.

Thanks and regards,
Arunan


On 7/20/06, Martin Gainty <mgainty@hotmail.com> wrote:
>
> Hello Arun-
>
> What happens when you set the session-timeout to sufficiently high value
> in your main webapps web.xml
> <session-config>
>      <session-timeout>300</session-timeout>
> </session-config>
>
> ???
> Martin --
> *********************************************************************
> This email message and any files transmitted with it contain confidential
> information intended only for the person(s) to whom this email message is
> addressed.  If you have received this email message in error, please
> notify
> the sender immediately by telephone or email and destroy the original
> message without making a copy.  Thank you.
>
>
>
> ----- Original Message -----
> From: "Arunan Kannan" <arunank@gmail.com>
> To: <users@tomcat.apache.org>
> Sent: Thursday, July 20, 2006 1:09 AM
> Subject: Re: Tomcat shutdowns unexpectedly - Please help
>
>
> > Please help....:(
> >
> >>
> >> Hi All,
> >>
> >> My problem seems to be very peculiar and haven't heard this before.
> >> The tomcat gets shutdown unexpectedly after 3 hours only on this
> >> particular system.
> >> the same tomcat with same confgiurations when run on a other system, it
> >> runs properly and there is no problem.
> >>
> >> on this particular system the problem occurs always.
> >>  # uname -a
> >> SunOS CBT 5.8 Generic_117350-36 sun4u sparc SUNW,Sun-Blade-1000
> >> dunno what to do. i have tried all.. nothing is fruitfull.
> >>
> >> Also it is very amazing that when i run a simple script at background
> >> which will echo hello once in 10 minute and is infite...the problem
> doesn't
> >> occurs...dunno why...
> >>
> >> while [ true ]
> >> do
> >>         echo "hello"
> >>         sleep 600
> >> done
> >>
> >> why?
> >> whats the problem?
> >> How to resolve?
> >>
> >> I am very much confused.
> >> Please help.
> >>
> >> Thanks again,
> >> Thanks and regards,
> >>  Arunan
> >>
> >>
> >>  On 7/18/06, Cosio, Raul <jose_raul_cosio@merck.com> wrote:
> >> >
> >> > David,
> >> >
> >> > - Do you have in your web.xml some kind of <servlet> tag sometimes
> used
> >> > to start a background thread that might be causing the problem?
> >> > Unfortunately I work with WinXP and not everithing is written to
> >> > catalina.out, what I do is run tomcat in a DOS prompt, if it hangs
> then
> >> > I can read all the output generated, sometimes caused by the JVM...
> >> >
> >> > - Are you trying to open de /admin tool but it's not installed
> already
> >> > on your server?
> >> >
> >> > -----Original Message-----
> >> > From: Arunan Kannan [mailto:arunank@gmail.com]
> >> > Sent: Martes, 11 de Julio de 2006 09:54 a.m.
> >> > To: Tomcat Users List; Martin Gainty
> >> > Subject: Re: Tomcat shutdowns unexpectedly - Please help
> >> >
> >> >
> >> > Hi David, Martin, and Alireza,
> >> >
> >> > Thank you very much for your comments and suggestions. Thanks a lot.
> >> >
> >> > Hi David,
> >> > There is no logs corresponding to this shutdown anywhere on the
> system.
> >> > I
> >> > couldn't find any thing relevent to this crash on syslog or at any
> other
> >> > place. Thanks for your help.
> >> >
> >> > Hi Martin,
> >> > Here is the log from catalina.out file. Please have a look at it.
> >> > Jul 10, 2006 11:57:18 PM org.apache.coyote.http11.Http11Protocol init
> >> > INFO: Initializing Coyote HTTP/1.1 on http-8080
> >> > Starting service Tomcat-Standalone
> >> > Apache Tomcat/4.1.31
> >> > Jul 10, 2006 11:57:21 PM org.apache.coyote.http11.Http11Protocolstart
> >> > INFO: Starting Coyote HTTP/1.1 on http-8080
> >> > Jul 10, 2006 11:57:21 PM org.apache.jk.common.ChannelSocket init
> >> > INFO: JK2: ajp13 listening on /0.0.0.0:8009
> >> > Jul 10, 2006 11:57:21 PM org.apache.jk.server.JkMain start
> >> > INFO: Jk running ID=0 time=2/53  config=/temp/jakarta-tomcat-4.1.31
> >> > /conf/jk2.pro
> >> > perties
> >> > Stopping service Tomcat-Standalone
> >> >
> >> > and here are the logs from localhost_admin_log.2006- 07-10.txt
> >> >
> >> > 2006-07-11 05:01:40 StandardContext[/admin]: Servlet /admin threw
> load()
> >> > excepti
> >> > on
> >> > javax.servlet.ServletException: Wrapper cannot find servlet class
> >> > org.apache.web
> >> > app.admin.ApplicationServlet or a class it depends on
> >> >        at org.apache.catalina.core.StandardWrapper.loadServlet
> >> > (StandardWrapper.
> >> > java:844)
> >> > 6)      at org.apache.catalina.core.StandardWrapper.load(
> >> > StandardWrapper.java:77
> >> > t.ja
> >> >
> 3363)rg.apache.catalina.core.StandardContext.loadOnStartup(StandardConte
> >> > x
> >> > 586)    at org.apache.catalina.core.StandardContext.start(
> >> > StandardContext.java:3
> >> > .java:774) org.apache.catalina.core.ContainerBase.addChildInternal
> >> > (ContainerBase
> >> > 0)      at org.apache.catalina.core.ContainerBase.addChild(
> >> > ContainerBase.java:76
> >> > ----
> >> > --at java.lang.reflect.Method.invoke(Method.java:324)
> >> >        at
> >> > org.apache.catalina.startup.Bootstrap.main (Bootstrap.java:156)
> >> >
> >> > 2006-07-11 05:01:40 StandardWrapper[/admin:invoker]: Loading
> container
> >> > servlet i
> >> > nvoker
> >> >
> >> > I couldn't understand much. Can you please let me know some more info
> >> > about
> >> > this.
> >> >
> >> > As you said, I tried to find some timeout parameters in the conf
> files.
> >> >
> >> > <!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 9080 -->
> >> > <Connector className="org.apache.coyote.tomcat4.CoyoteConnector "
> >> >           port="9080" minProcessors="5" maxProcessors="75"
> >> >           enableLookups="true" redirectPort="9443"
> >> >           acceptCount="100" debug="0" connectionTimeout="20000"
> >> >           useURIValidationHack="false" disableUploadTimeout="true" />
> >> > <!-- Note : To disable connection timeouts, set connectionTimeout
> value
> >> > to -1 -->
> >> >
> >> >
> >> > In the server.xml the ConnectionTimeout is set to 20000. I will
> change
> >> > that
> >> > to 0 and let you know the results. Thanks for your help.
> >> >
> >> > Hi Alireza,
> >> >
> >> > The tomcat I am using is not configured with apache.
> >> >
> >> > Initially I run some sample application and left it ideal for some 3
> to
> >> > 4
> >> > hr. There is no action done in this time. Then the tomcat gets
> shutdown
> >> > unexpectedly.
> >> >
> >> > I will try your suggestion and let you know the result. Thanks for
> your
> >> > help.
> >> >
> >> > Thanks again for all,
> >> >
> >> > Thanks and Regards,
> >> >
> >> > Arunan
> >> >
> >> >
> >> > On 7/11/06, Martin Gainty <mgainty@hotmail.com> wrote:
> >> > >
> >> > > I would also look at workers.properties files and make sure
> >> > > socket_KeepAlive is set on
> >> > > Also socket_timeout is set to 0 so it never times out
> >> > >
> >> > > M-
> >> > >
> *********************************************************************
> >> > > This email message and any files transmitted with it contain
> >> > confidential
> >> > > information intended only for the person(s) to whom this email
> message
> >> > is
> >> > > addressed.  If you have received this email message in error,
> please
> >> > > notify
> >> > > the sender immediately by telephone or email and destroy the
> original
> >> > > message without making a copy.  Thank you.
> >> > >
> >> > >
> >> > >
> >> > > ----- Original Message -----
> >> > > From: "Mr Alireza Fattahi" <afattahi@yahoo.com>
> >> > > To: "Tomcat Users List" <users@tomcat.apache.org>; "Martin Gainty"
> <
> >> > > mgainty@hotmail.com>
> >> > > Sent: Tuesday, July 11, 2006 9:45 AM
> >> > > Subject: Re: Tomcat shutdowns unexpectedly - Please help
> >> > >
> >> > >
> >> > > > Hi,
> >> > > >
> >> > > > I hope I get it correctly, the Tomcat shutdowns when it is ideal.
> >> > That
> >> > > means no one is working with it and there is no connection to it.
> >> > > > If I assume correct and this is the case, please let me know
if
> this
> >> > > shutdown happens when there are some connections to it.
> >> > > > We had this problem once with Apache and OracleAS, the OracleAS
> >> > shouted
> >> > > down itself when it does not received any requests (made a
> suicide!)
> >> > We end
> >> > > up writing a small program which was connected to Tomcat every 10
> min
> >> > and
> >> > > requested a dummy page. It solved it.
> >> > > >
> >> > > > P.S: Did you configure your Tomcat with Apache?
> >> > > >
> >> > > > Hope it helps you!
> >> > > >
> >> > > >
> >> > > >
> >> > > > Martin Gainty < mgainty@hotmail.com> wrote: If the app
is
> crashing
> >> > then
> >> > > you would see exceptions thrown in wither catalina.out /
> >> > > stdout_YYYYMMDD.log / stderr_YYYYMMDD.log
> >> > > > If the service is crashing on startup(misconfigured JVM, startup
> >> > jars
> >> > > missing) then check the jakarta_service_YYYYMMDD.log
> >> > > >
> >> > > > HTH,
> >> > > > Martin--
> >> > > >
> >> > *********************************************************************
> >> > > > This email message and any files transmitted with it contain
> >> > > confidential
> >> > > > information intended only for the person(s) to whom this email
> >> > message
> >> > > is
> >> > > > addressed.  If you have received this email message in error,
> please
> >> >
> >> > > notify
> >> > > > the sender immediately by telephone or email and destroy the
> >> > original
> >> > > > message without making a copy.  Thank you.
> >> > > >
> >> > > >
> >> > > >
> >> > > > ----- Original Message -----
> >> > > > From: "David Smith"
> >> > > > To: "Tomcat Users List"
> >> > > > Sent: Tuesday, July 11, 2006 7:51 AM
> >> > > > Subject: Re: Tomcat shutdowns unexpectedly - Please help
> >> > > >
> >> > > >
> >> > > >> I'm no expert, but off the top of my head it appears your
JVM is
> >> > > >> crashing.  Especially true if there is absolutely no logging
> data
> >> > just
> >> > > >> before the process stops.  You may have indications of what's
> >> > happening
> >> > > >> in other log files like syslog or a core dump file.  You
may
> also
> >> > want
> >> > > >> to look at bug reports for your OS and JDK.
> >> > > >>
> >> > > >>
> >> > > >> --David
> >> > > >>
> >> > > >> Arunan Kannan wrote:
> >> > > >>
> >> > > >>> Hi,
> >> > > >>>
> >> > > >>> Please help me in guiding to find out the root cause
of this
> >> > problem.
> >> > > >>>
> >> > > >>> Tomcat Version: jakarta-tomcat-4.1.31
> >> > > >>> Server OS: SUN OS 5.8
> >> > > >>> JDK version: j2sdk1.4.2_11
> >> > > >>>
> >> > > >>> Initially the tomcat server is running perfectly and
there is
> no
> >> > > problem.
> >> > > >>> There is no operation done on the server. Simply it is
kept
> idle.
> >> > > >>> After some 3 or 4 hours the tomcat gets shutdown unexpectedly.
> >> > > >>>
> >> > > >>> This happens repeatedly. Whenever I start the server,
after
> some 3
> >> >
> >> > or
> >> > > 4
> >> > > >>> hours it gets stopped.
> >> > > >>> There is not enough log to find the cause.
> >> > > >>>
> >> > > >>> I have posted this query in lot of forum and still it
is a hard
> >> > luck.
> >> > > >>> I configured debug=5 in server.xml under conf directory
to get
> >> > maximum
> >> > > >>> log,
> >> > > >>> then also no use.
> >> > > >>> There is no application running in the tomcat server.
> >> > > >>>
> >> > > >>> Simply the when tomcat is started in this SUN server
after a
> few
> >> > ours
> >> > > it
> >> > > >>> stops always.
> >> > > >>> Please help me.
> >> > > >>> Please let me know if I need to give more information.
> >> > > >>>
> >> > > >>> Thanks in advance,
> >> > > >>> Thanks and Regards,
> >> > > >>> Arunan
> >> > > >>>
> >> > > >>
> >> > > >>
> >> > > >>
> >> > ---------------------------------------------------------------------
> >> > > >> To start a new topic, e-mail: users@tomcat.apache.org
> >> > > >> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> >> > > >> For additional commands, e-mail: users-help@tomcat.apache.org
> >> > > >>
> >> > > >>
> >> > > >
> >> > > >
> >> > > > ~Regards,
> >> > > > ~~Alireza Fattahi
> >> > > >
> >> > > > ---------------------------------
> >> > > > Now you can scan emails quickly with a reading pane. Get the
new
> >> > Yahoo!
> >> > > Mail.
> >> >
> >> >
> >> >
> ------------------------------------------------------------------------------
> >> >
> >> > Notice:  This e-mail message, together with any attachments, contains
> >> > information of Merck & Co., Inc. (One Merck Drive, Whitehouse
> Station, New
> >> > Jersey, USA 08889), and/or its affiliates (which may be known outside
> the
> >> > United States as Merck Frosst, Merck Sharp & Dohme or MSD and in
> Japan, as
> >> > Banyu) that may be confidential, proprietary copyrighted and/or
> legally
> >> > privileged. It is intended solely for the use of the individual or
> entity
> >> > named on this message.  If you are not the intended recipient, and
> have
> >> > received this message in error, please notify us immediately by reply
> e-mail
> >> > and then delete it from your system.
> >> >
> >> >
> ------------------------------------------------------------------------------
> >> >
> >>
> >>
> >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message