tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Wang" <pw...@uclink.berkeley.edu>
Subject RE: Load Balance not working for mod_jk???
Date Fri, 21 Jul 2006 20:26:37 GMT
Things worked after I modify the workers.properties to use
Worker.router.balanced_workers
Instead of
Worker.router.balance_workers

Based on the TOMCAT documentation the balance_workers should be used instead of
the balanced_workers after MOD_JK version 1.2.7.


Did anybody know how to check the version of the MOD_JK?

Thanks
Pat

-----Original Message-----
From: Patrick Wang [mailto:pwang@uclink.berkeley.edu] 
Sent: Friday, July 21, 2006 11:55 AM
To: 'Tomcat Users List'
Subject: RE: Load Balance not working for mod_jk???

Thanks for the info.

The latest binary download 1.2.15 for Linux on tomcat website indicate the
latest version is 1.2.14.


Attach a log, it looks like the balance worker router is found, why it tried to
connect port 8007, it suppose to delegate the work to TOMCAT_INSTANCE1 which
listen on port 8009 or TOMCAT_instance2 which listen on port 8010.


Thanks
Pat

[Fri Jul 21 11:47:05 2006]  [jk_uri_worker_map.c (459)]: Attempting to map URI
'/ucdiscovery'
[Fri Jul 21 11:47:05 2006]  [jk_uri_worker_map.c (473)]:
jk_uri_worker_map_t::map_uri_to_worker, Found an exact match router ->
/ucdiscovery
[Fri Jul 21 11:47:05 2006]  [mod_jk.c (1689)]: Into handler r->proxyreq=0
r->handler=jakarta-servlet r->notes=165738416 worker=router
[Fri Jul 21 11:47:05 2006]  [jk_worker.c (90)]: Into wc_get_worker_for_name
router
[Fri Jul 21 11:47:05 2006]  [jk_worker.c (94)]: wc_get_worker_for_name, done
found a worker
[Fri Jul 21 11:47:05 2006]  [mod_jk.c (472)]: agsp=80 agsn=ea hostn=ea
shostn=ea.iucrp.org cbsport=0 sport=0 
[Fri Jul 21 11:47:05 2006]  [jk_ajp12_worker.c (201)]: Into
jk_worker_t::get_endpoint
[Fri Jul 21 11:47:05 2006]  [jk_ajp12_worker.c (96)]: Into
jk_endpoint_t::service
[Fri Jul 21 11:47:05 2006]  [jk_connect.c (136)]: Into jk_open_socket
[Fri Jul 21 11:47:05 2006]  [jk_connect.c (143)]: jk_open_socket, try to connect
socket = 14 to 127.0.0.1:8007
[Fri Jul 21 11:47:05 2006]  [jk_connect.c (159)]: jk_open_socket, after connect
ret = -1
[Fri Jul 21 11:47:05 2006]  [jk_connect.c (188)]: jk_open_socket, connect()
failed errno = 111

-----Original Message-----
From: Mladen Turk [mailto:mladen.turk@jboss.com] 
Sent: Friday, July 21, 2006 10:45 AM
To: Tomcat Users List
Subject: Re: Load Balance not working for mod_jk???

Patrick Wang wrote:
> Thanks for the comments, I checked this carefully several times to make sure
> only router appear in the worker list and JkMount router only.
>

Then turn on the debug log level for mod_jk,
and post the startup log messages.

Anyhow, at least 1.2.15 is suggested. (1.2.14 is broken).

Regards,
Mladen.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message