tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "simon jones" <si...@saq.co.uk>
Subject RE: HTTP Status 503 - Servlet admin.login_jsp is currently unavailable
Date Thu, 13 Jul 2006 11:53:36 GMT
Think it is most likely me having the files in the wrong place by the
looks of it, here's my dirs with file list:

/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/Catalina/localhost 

drwxr-xr-x  2 tomcat nobody 4096 Jul 12 15:27 ./
drwxr-xr-x  3 tomcat nobody 4096 Mar 26  2005 ../
-rw-------  1 root   root    566 Jul 12 15:27 admin.xml
-rw-------  1 tomcat nobody  299 Mar 26  2005 host-manager.xml
-rw-------  1 tomcat nobody  454 Mar 26  2005 manager.xml

/usr/src/apache-tomcat-5.5.17/server/webapps/admin

drwxr-xr-x  13 root root 4096 Apr 14 19:09 ./
drwxr-xr-x   3 root root 4096 Jul 10 16:53 ../
-rw-r--r--   1 root root 2151 Apr 14 19:09 admin.css
-rw-r--r--   1 root root  586 Apr 14 19:09 admin.xml
drwxr-xr-x   2 root root 4096 Apr 14 19:09 connector/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 context/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 host/
drwxr-xr-x   2 root root 4096 Jul 10 16:53 images/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 realm/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 resources/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 server/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 service/
-rw-r--r--   1 root root  344 Apr 14 19:09 tree-control-test.css
drwxr-xr-x   2 root root 4096 Apr 14 19:09 users/
drwxr-xr-x   2 root root 4096 Apr 14 19:09 valve/
drwxr-xr-x   3 root root 4096 Jul 10 16:53 WEB-INF/

Simon

> -----Original Message-----
> From: David Smith [mailto:dns4@cornell.edu] 
> Sent: 13 July 2006 12:49
> To: Tomcat Users List
> Subject: Re: HTTP Status 503 - Servlet admin.login_jsp is 
> currently unavailable
> 
> There has to be some messages about the admin webapp.  The 
> only way to not have any is if admin.xml is not stored in the 
> correct place.  Even bad permissions should generate an 
> exception of some sort attempting to read it.  So to recap, 
> here's how your file structure looks and all the permissions 
> are set correctly?:
> 
> /usr/local/jakarta/jakarta-tomcat-5.5.9
>     - conf
>         - Catalina
>             - localhost
>                 ROOT.xml
>                 manager.xml
>                 admin.xml (hopefully the original as provided 
> by the downloaded admin webapp distribution)
>     - server
>         - lib
>             [server jar files here]
>         - webapps
>             manager
>             admin
>     - webapps
>         - ROOT
> 
> Admittedly I've abbreviated and not included some 
> directories.  Also, do you have a catalina.out log file?  
> What does that show.
> 
> --David
> 
> simon jones wrote:
> 
> >Hi David,
> >
> >Ok I did as instructed and tried the admin.  Now I get the "Tomcat's 
> >administration web application is no longer installed by default.
> >Download and install the "admin" package to use it. " error.
> >
> >No entries in the log either, where next?
> >
> >Cheers,
> >
> >Simon
> >
> >  
> >
> >>-----Original Message-----
> >>From: David Smith [mailto:dns4@cornell.edu]
> >>Sent: 12 July 2006 19:58
> >>To: Tomcat Users List
> >>Subject: Re: HTTP Status 503 - Servlet admin.login_jsp is currently 
> >>unavailable
> >>
> >>I also don't see even one reference to the admin webapp.  
> >>This tells me something fishy is going on.
> >>
> >>Try this:
> >>
> >>First, I see you copied the admin webapp to server/webapps 
> instead of 
> >>moving it.  Delete the admin webapp in 
> >>/usr/local/jakarta/jakarta-tomcat-5.5.9/webapps.  It's just 
> going to 
> >>be confusing to leave a copy there (for both you and tomcat).
> >>
> >>Second, there should be an admin.xml file in the same 
> archive you got 
> >>the admin webapp from.  That should be placed in 
> >>/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/Catalina/localhos
> >>t right along side manager.xml.
> >>
> >>Now restart tomcat and take a look for messages related to 
> the admin 
> >>webapp.
> >>
> >>--David
> >>
> >>simon jones wrote:
> >>
> >>    
> >>
> >>>Hi David,
> >>>
> >>>Ok looks as thought the files are in the correct place:
> >>>
> >>>cp -r admin /usr/local/jakarta/jakarta-tomcat-5.5.9/server/webapps
> >>>
> >>>There's nothing in tail -f
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/logs/tomcat.log
> >>>
> >>>When I do a tail and access the admin it doesn't do anything.
> >>>
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking 
> context[] redeploy 
> >>>resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/webapps/ROOT/META-INF
> >>>      
> >>>
> >>/context.x
> >>    
> >>
> >>>m
> >>>l
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking context[] reload 
> >>>resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/webapps/ROOT/WEB-IN
> F/web.xml
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking context[] reload 
> >>>resource /usr/local/jakarta/jakarta-tomcat-5.5.9/conf/context.xml
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking 
> context[/manager] 
> >>>redeploy resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/server/webapps/manager
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking 
> context[/manager] 
> >>>redeploy resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/Catalina/localho
> >>>      
> >>>
> >>st/manager.
> >>    
> >>
> >>>xml
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking 
> context[/manager] 
> >>>reload resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/context.xml
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.startup.HostConfig - Checking 
> context[/manager] 
> >>>reload resource 
> >>>/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/Catalina/localho
> >>>      
> >>>
> >>st/manager.
> >>    
> >>
> >>>xml
> >>>DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.loader.WebappClassLoader - modified()  DEBUG 
> >>>ContainerBackgroundProcessor[StandardEngine[Catalina]]
> >>>org.apache.catalina.loader.WebappClassLoader - modified()
> >>>
> >>>-----Original Message-----
> >>>From: David Smith [mailto:dns4@cornell.edu]
> >>>Sent: 12 July 2006 17:38
> >>>To: Tomcat Users List
> >>>Subject: Re: HTTP Status 503 - Servlet admin.login_jsp is 
> currently 
> >>>unavailable
> >>>
> >>>Did you store the admin webapp in server/webapps where it 
> belongs?  
> >>>Also check your logs.  There should be an exception trace
> >>>      
> >>>
> >>just before
> >>    
> >>
> >>>the place where this was marked as unavailable.
> >>>
> >>>--David
> >>>
> >>>simon jones wrote:
> >>>
> >>> 
> >>>
> >>>      
> >>>
> >>>>Hi, can anyone help me with this one?  Thanks!
> >>>>
> >>>>I've installed tomcat - no probs - manager works great as 
> does the 
> >>>>installation but I can't get the admin working, I know this
> >>>>        
> >>>>
> >>has been
> >>    
> >>
> >>>>posted before but I can't find a fix so I'm also 
> providing as much 
> >>>>information as possible with this post.
> >>>>
> >>>>When I call the admin page I get the following error:
> >>>>
> >>>>HTTP Status 503 - Servlet admin.login_jsp is currently unavailable
> >>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>----------
> >>    
> >>
> >>>>-
> >>>>-
> >>>>--------
> >>>>
> >>>>type Status report
> >>>>
> >>>>message Servlet admin.login_jsp is currently unavailable
> >>>>
> >>>>description The requested service (Servlet admin.login_jsp is 
> >>>>currently
> >>>>unavailable) is not currently available.
> >>>>
> >>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>----------
> >>    
> >>
> >>>>-
> >>>>-
> >>>>--------
> >>>>
> >>>>Apache Tomcat/5.5.9
> >>>>
> >>>>I have my admin files installed in the following locations:
> >>>>
> >>>>/usr/local/jakarta/jakarta-tomcat-5.5.9/conf/Catalina/localh
> >>>>        
> >>>>
> >>ost/admin.
> >>    
> >>
> >>>>x
> >>>>m
> >>>>l
> >>>>/usr/local/jakarta/jakarta-tomcat-5.5.9/webapps/server/webap
> >>>>        
> >>>>
> >>ps/admin/a
> >>    
> >>
> >>>>d
> >>>>m
> >>>>in.xml
> >>>>
> >>>>thanks
> >>>>
> >>>>Simon Jones
> >>>>SAQ Group
> >>>>
> >>>>Simon Jones
> >>>>SAQ Group
> >>>>Tel: 0870 737 7707
> >>>>VoIP: 4822813
> >>>>Fax: 0870 737 7708
> >>>>simon@saq.co.uk
> >>>>http://www.saqnet.co.uk AS29219
> >>>>SAQ Group providers of communications services for UK Business.
> >>>>DSL : Domains : Email : Hosting : CoLo : Servers : Racks 
> : Transit :
> >>>>Backups : Managed Networks : Remote Support.
> >>>>
> >>>>------------------------------------------------------------
> >>>>        
> >>>>
> >>---------
> >>    
> >>
> >>>>To start a new topic, e-mail: users@tomcat.apache.org To
> >>>>        
> >>>>
> >>unsubscribe,
> >>    
> >>
> >>>>e-mail: users-unsubscribe@tomcat.apache.org
> >>>>For additional commands, e-mail: users-help@tomcat.apache.org
> >>>>
> >>>>
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>-----------------------------------------------------------
> ----------
> >>>To start a new topic, e-mail: users@tomcat.apache.org To 
> unsubscribe,
> >>>e-mail: users-unsubscribe@tomcat.apache.org
> >>>For additional commands, e-mail: users-help@tomcat.apache.org
> >>>
> >>>
> >>>-----------------------------------------------------------
> ----------
> >>>To start a new topic, e-mail: users@tomcat.apache.org To
> >>>      
> >>>
> >>unsubscribe,
> >>    
> >>
> >>>e-mail: users-unsubscribe@tomcat.apache.org
> >>>For additional commands, e-mail: users-help@tomcat.apache.org
> >>>
> >>> 
> >>>
> >>>      
> >>>
> >>------------------------------------------------------------
> ---------
> >>To start a new topic, e-mail: users@tomcat.apache.org To 
> unsubscribe, 
> >>e-mail: users-unsubscribe@tomcat.apache.org
> >>For additional commands, e-mail: users-help@tomcat.apache.org
> >>
> >>
> >>--
> >>No virus found in this incoming message.
> >>Checked by AVG Free Edition.
> >>Version: 7.1.394 / Virus Database: 268.9.10/385 - Release
> >>Date: 11/07/2006
> >> 
> >>
> >>    
> >>
> >
> >---------------------------------------------------------------------
> >To start a new topic, e-mail: users@tomcat.apache.org To 
> unsubscribe, 
> >e-mail: users-unsubscribe@tomcat.apache.org
> >For additional commands, e-mail: users-help@tomcat.apache.org
> >
> >  
> >
> 
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org To 
> unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.394 / Virus Database: 268.9.10/387 - Release 
> Date: 12/07/2006
>  
> 

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message