tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remacle, F \(Francois\)" <f.rema...@dl.ac.uk>
Subject RE: Odd problem with Java Web service deployment
Date Tue, 04 Jul 2006 07:29:24 GMT
Hi Frank,

Thanks for your reply,

In fact it is finding these listeners (or the error message is
misleading me), it is the javax.servlet.AttributeContextListener that
its not finding which is odd since the others app finds it... 

-----Original Message-----
From: Franck Borel [mailto:borel@ub.uni-freiburg.de] 
Sent: 03 July 2006 13:06
To: Tomcat Users List
Subject: Re: Odd problem with Java Web service deployment


> According to all different things I have seen on the internet they 
> sometimes talks about the classpath, however even if I add explicitely

> the servlet-api.jar that is in $CATALINA_HOME/common/lib on the 
> classpath inside catalina.sh or on the system classpath that does not 
> change anything. And I doubt the problem comes from there since other 
> examples using classes relying on this packages works fine, only mine 
> crashes down not finding these classes.
>
>   
Your application is searching in your webapps-environment and doesn't
find any Listener Have you tried to include the context-classees in your
webapps directory like this?
/webapps/<your>-Application/WEB-INF/classes/listeners/ContextListener.cl
ass

-- Franck




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message