tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rache <rachehernan...@yahoo.com>
Subject Re: Missing Request Parameters
Date Mon, 31 Jul 2006 16:15:45 GMT

This is how the code redirects:

		if (redirectURL.toUpperCase().startsWith("/SERVLET"))
		{
			// routing to another request to the servlet...
			response.sendRedirect(request.getContextPath() + redirectURL);
		}
		else if (redirectURL.toUpperCase().startsWith("HTTP"))
		{
			// routing to another request to the servlet...
			response.sendRedirect(redirectURL);
		}
		else
		{
			// routing to a JSP...
			getRequestDispatcher(redirectURL).forward(request, response);
		}


-Jon, we have enabled the RequestDumperValve in the tomcat server.xml to
enable request logging. That way, we are able to monitor the requests coming
in. The logs helped us to see that no parameters where set in the request.

This application is connected to IIS thru the AJP connectors. Aside from the
parameter-setting code which I need to check, could this connection  also
cause request parameters to be dropped? I have quite a bit of a problem
checking the urls with parameters set since this happens in production and
happens on and off. I can't even see the page source to check on the url set
since the pages aren't cached. Any tips on these?

I'm really grateful for all your inputs!
-- 
View this message in context: http://www.nabble.com/Missing-Request-Parameters-tf2018230.html#a5578922
Sent from the Tomcat - User forum at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message