tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rache <rachehernan...@yahoo.com>
Subject lost jsp session on tomcat
Date Wed, 26 Jul 2006 16:20:03 GMT

I'm currently having problems with getting session data in the jsp. The data
was set in the session in a servlet. The jsp is just an href link from the
current page. When its clicked, it doesn't load up because of an exception
thrown when it can't find the session data. This works when the jsp is not
called directly thru the link but when routed thru a servlet.Weird thing is
that when you refresh on the unfinished page, sometimes it works, indicating
that the session is still there but can't find the right one.

This works well in a standalone mode. But when its done on a cluster of
tomcat servers/instances, it does this unusual behavior. I don't think
there's a problem with the code since its working fine by a standalone/test
server. Is there any configuration I need to check.

This is using a tomcat 5.5 server linked to an apache web server. There are
3 tomcat instances working on 3 webservers.
-- 
View this message in context: http://www.nabble.com/lost-jsp-session-on-tomcat-tf2004750.html#a5506351
Sent from the Tomcat - User forum at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message