tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Load Balance not working for mod_jk???
Date Mon, 24 Jul 2006 18:00:25 GMT
OK, then we are back to the suggestion: download and build a new one.
You might want to pick 1.2.18 from http://tomcat.apache.org/dev/dist/,
it's not yet officially released, but we are in the process of voting
about it and the results look promising. The latest officially released
version is 1.2.15 to be found at

http://tomcat.apache.org/download-connectors.cgi

Rainer

Patrick Wang schrieb:
> You are Right, the Strings things work great, which shows the version of the
> mod_jk 1.2.6.
> 
> Pat
> 
> -----Original Message-----
> From: Rainer Jung [mailto:rainer.jung@kippdata.de] 
> Sent: Monday, July 24, 2006 10:26 AM
> To: Tomcat Users List
> Subject: Re: Load Balance not working for mod_jk???
> 
> It will appear in the error log, so you configured everything that's
> needed. What about the "strings" way of determining the version (the
> second option I gave in my previous mail)?
> 
> Patrick Wang schrieb:
>> Thanks for the info.
>>
>> However my Apache log did not log any information listed below.
>>
>> I checked both error_log and access_log information. There seems that you can
>> setup the log level for error_log using flags like "info"/"debug".
>>
>> However there is not such as place for the access_log, can anybody shed some
>> light on? My Apache version is 2.5.0.24.
>>
>> Attached my part of the httpd.conf.
>>
>> ====================================================================
>> ErrorLog logs/error_log
>>
>> #
>> # LogLevel: Control the number of messages logged to the error_log.
>> # Possible values include: debug, info, notice, warn, error, crit,
>> # alert, emerg.
>> #
>> LogLevel debug
>>
>> #
>> # The following directives define some format nicknames for use with
>> # a CustomLog directive (see below).
>> #
>> LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\""
>> combined
>> LogFormat "%h %l %u %t \"%r\" %>s %b" common
>> LogFormat "%{Referer}i -> %U" referer
>> LogFormat "%{User-agent}i" agent
>>
>> # "combinedio" includes actual counts of actual bytes received (%I) and sent
>> (%O); this
>> # requires the mod_logio module to be loaded.
>> #LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I
> %O"
>> combinedio
>>
>> #
>> # The location and format of the access logfile (Common Logfile Format).
>> # If you do not define any access logfiles within a <VirtualHost>
>> # container, they will be logged here.  Contrariwise, if you *do*
>> # define per-<VirtualHost> access logfiles, transactions will be
>> # logged therein and *not* in this file.
>> #
>> #CustomLog logs/access_log common
>>
>> #
>> # If you would like to have separate agent and referer logfiles, uncomment
>> # the following directives.
>> #
>> #CustomLog logs/referer_log referer
>> #CustomLog logs/agent_log agent
>>
>> #
>> # For a single logfile with access, agent, and referer information
>> # (Combined Logfile Format), use the following directive:
>> #
>> CustomLog logs/access_log combined
>>
>>
>>
>> -----Original Message-----
>> From: Rainer Jung [mailto:rainer.jung@kippdata.de] 
>> Sent: Friday, July 21, 2006 11:15 PM
>> To: Tomcat Users List
>> Subject: Re: Load Balance not working for mod_jk???
>>
>> When you are starting or restarting Apache it should log a line similar 
>> to the following:
>>
>> [Sat Jul 22 07:59:41 2006] [notice] Apache/2.0.58 (Unix) DAV/2 
>> mod_jk/1.2.15 configured -- resuming normal operations
>>
>> It includes the mod_jk version (mod_jk/1.2.15).
>>
>> The same should be found via
>>
>> myserver% strings PATH_TO_MOD_JK/mod_jk.so | grep mod_jk/1.2
>>
>>  From your log output and a look at the revision history your version is 
>> most likely 1.2.6. You really should download a new one and build it via 
>> configure/make.
>>
>> Rainer
>>
>> Patrick Wang wrote:
>>> Things worked after I modify the workers.properties to use
>>> Worker.router.balanced_workers
>>> Instead of
>>> Worker.router.balance_workers
>>>
>>> Based on the TOMCAT documentation the balance_workers should be used instead
>> of
>>> the balanced_workers after MOD_JK version 1.2.7.
>>>
>>>
>>> Did anybody know how to check the version of the MOD_JK?
>>>
>>> Thanks
>>> Pat
>>>
>>> -----Original Message-----
>>> From: Patrick Wang [mailto:pwang@uclink.berkeley.edu] 
>>> Sent: Friday, July 21, 2006 11:55 AM
>>> To: 'Tomcat Users List'
>>> Subject: RE: Load Balance not working for mod_jk???
>>>
>>> Thanks for the info.
>>>
>>> The latest binary download 1.2.15 for Linux on tomcat website indicate the
>>> latest version is 1.2.14.
>>>
>>>
>>> Attach a log, it looks like the balance worker router is found, why it tried
>> to
>>> connect port 8007, it suppose to delegate the work to TOMCAT_INSTANCE1 which
>>> listen on port 8009 or TOMCAT_instance2 which listen on port 8010.
>>>
>>>
>>> Thanks
>>> Pat
>>>
>>> [Fri Jul 21 11:47:05 2006]  [jk_uri_worker_map.c (459)]: Attempting to map
> URI
>>> '/ucdiscovery'
>>> [Fri Jul 21 11:47:05 2006]  [jk_uri_worker_map.c (473)]:
>>> jk_uri_worker_map_t::map_uri_to_worker, Found an exact match router ->
>>> /ucdiscovery
>>> [Fri Jul 21 11:47:05 2006]  [mod_jk.c (1689)]: Into handler r->proxyreq=0
>>> r->handler=jakarta-servlet r->notes=165738416 worker=router
>>> [Fri Jul 21 11:47:05 2006]  [jk_worker.c (90)]: Into wc_get_worker_for_name
>>> router
>>> [Fri Jul 21 11:47:05 2006]  [jk_worker.c (94)]: wc_get_worker_for_name, done
>>> found a worker
>>> [Fri Jul 21 11:47:05 2006]  [mod_jk.c (472)]: agsp=80 agsn=ea hostn=ea
>>> shostn=ea.iucrp.org cbsport=0 sport=0 
>>> [Fri Jul 21 11:47:05 2006]  [jk_ajp12_worker.c (201)]: Into
>>> jk_worker_t::get_endpoint
>>> [Fri Jul 21 11:47:05 2006]  [jk_ajp12_worker.c (96)]: Into
>>> jk_endpoint_t::service
>>> [Fri Jul 21 11:47:05 2006]  [jk_connect.c (136)]: Into jk_open_socket
>>> [Fri Jul 21 11:47:05 2006]  [jk_connect.c (143)]: jk_open_socket, try to
>> connect
>>> socket = 14 to 127.0.0.1:8007
>>> [Fri Jul 21 11:47:05 2006]  [jk_connect.c (159)]: jk_open_socket, after
>> connect
>>> ret = -1
>>> [Fri Jul 21 11:47:05 2006]  [jk_connect.c (188)]: jk_open_socket, connect()
>>> failed errno = 111
>>>
>>> -----Original Message-----
>>> From: Mladen Turk [mailto:mladen.turk@jboss.com] 
>>> Sent: Friday, July 21, 2006 10:45 AM
>>> To: Tomcat Users List
>>> Subject: Re: Load Balance not working for mod_jk???
>>>
>>> Patrick Wang wrote:
>>>> Thanks for the comments, I checked this carefully several times to make sure
>>>> only router appear in the worker list and JkMount router only.
>>>>
>>> Then turn on the debug log level for mod_jk,
>>> and post the startup log messages.
>>>
>>> Anyhow, at least 1.2.15 is suggested. (1.2.14 is broken).
>>>
>>> Regards,
>>> Mladen.
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message