tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garthfield Carter <>
Subject Tomcat admin application "HTTP Status 500" problem
Date Fri, 21 Jul 2006 00:16:33 GMT

I have an issue with the Tomcat "admin" application. I get "HTTP Status 
500" errors whenever I click on any of the "User Definition" menu items 
such as Users, Groups or Roles. The exact error I get reported on screen 
in the HTTP Status 500 section is:
type* Status report*
message* _Error retrieving attribute users_*
description* _The server encountered an internal error (Error retrieving 
attribute users) that prevented it from fulfilling this request.

_I'm using the following software version:

Tomcat 5.0.28
Sun JDK 1.5.0_06

My server.xml looks like this:

<?xml version='1.0' encoding='utf-8'?>
<Server port="8121">

        <Resource auth="Container" name="UserDatabase" 
        <ResourceParams name="UserDatabase">

<Service name="Tomcat-Apache">
<Connector maxProcessors="75" port="8221" protocol="AJP/1.3" 
<Engine defaultHost="localhost" name="alberta">
<Host appBase="/home/tomcat/tomcat/webapps" deployOnStartup="false" 
        <Logger className="org.apache.catalina.logger.FileLogger" 
directory="/home/tomcat/logs" prefix="tomcat." suffix=".txt" 
        <Context path="/" docBase="../../public_html" debug="0" 
        <Context path="/admin" debug="0" privileged="true" docBase="admin"/>
<Realm className="org.apache.catalina.realm.UserDatabaseRealm"/>

I've searched Google and found one other person with this problem but no 
answers at all.

Any ideas would be greatly appreciated.

Garthfield Carter

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message