tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Delbecq <david.delb...@oma.be>
Subject Re: getting "?" instead of "¢"
Date Mon, 17 Jul 2006 10:17:44 GMT
(Sorry for the double post, alias issue)
David Delbecq wrote:
> This is not a matter of saving the jsp/html file on server with the good
> charset, this is a matter of using the correct entity reference (&cent;)
> which is supposed to be displayable by any html 2.0 compliant browser.
> Ronald Klop wrote:
>> On Mon Jul 17 08:55:56 CEST 2006 Tomcat Users List 
>> <users@tomcat.apache.org> wrote:
>>> Hi All,
>>>
>>> I need some help from you. I need to display Cent(¢) symbol on 
>>> browser. I am
>>> getting ? symbol instead, what could be the problem, please explain me.
>>>
>>> Thank you.
>>>
>>> balaraju
>> Hello,
>>
>> Use the method ServletResponse.setCharacterEncoding("UTF-8") in a 
>> Servlet or contentType="text/html; charset=UTF-8" in a jsp page.
>> http://java.sun.com/products/jsp/syntax/1.2/syntaxref1210.html#15653
>>
>> But charset issues are tricky because all you files need to use a 
>> known charset. And if you use a database it needs to have a supported 
>> charset also.
>> If your editor saves files in iso-8859-1 the problem is already there 
>> and the browser wil never see the right character. So you need to 
>> debug where the character is correct for the last time.
>>
>> Ronald.
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message