tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid...@pidster.com>
Subject Re: Tomcat under JBoss
Date Wed, 05 Jul 2006 16:23:07 GMT
Can you execute an arbitrary JSP scriptlet in the page, or does that get
ignored too?

Pid wrote:
> And the taglibs are definitely being imported on the page in question?
> 
> Richard Doust wrote:
>> Config files are straight out of the box as Tomcat is deployed under
>> JBoss 4.0.4.
>> The web.xml file for the application has the obligatory:
>>     <jsp-config>
>>         <taglib>
>>            <taglib-uri>http://java.sun.com/jsp/jstl/core</taglib-uri>
>>         </taglib>
>>         <taglib>
>>            <taglib-uri>http://java.sun.com/jsp/jstl/fmt</taglib-uri>
>>         </taglib>
>>     </jsp-config>
>> Thanks for any help. If you need more information, please ask.
>> I had thought that someone must know of some manner in which Tomcat's
>> support for JSTL differs from Jetty's.
>>
>> On Jul 5, 2006, at 10:38 AM, Pid wrote:
>>
>>> error logs?
>>> config files?
>>>
>>> define "does not work" with some more precision and we might be able to
>>> help...
>>>
>>>
>>>
>>> Richard Doust wrote:
>>>> I need help getting Tomcat to process JSTL tags when an ear is deployed
>>>> to JBoss 4.0.4 with Tomcat 5.5.17.
>>>> The same application that works with JBoss 4.0.1 and Jetty 5.1.4 does
>>>> not work with JBoss 4.0.4 with Tomcat 5.5.17. JSTL tags are sent to the
>>>> client's browser unprocessed.
>>>> Tomcat does not seem to be honoring the contract for the servlet
>>>> container. I am packaging the standard.jar and jstl.jar files in my
>>>> WEB-INF/lib directory. I know they're being found, because if I remove
>>>> them I get Class Not Found exceptions for the tag support classes.
>>>> However, maybe there's some underlying support file that's available
>>>> with Jetty that isn't with Tomcat that I also need in my WEB-INF/lib
>>>> that I don't have there. I don't know. I'm pulling my hair out. I've
>>>> spent 24 hours trying everything I can think of. Nothing works. No error
>>>> messages or other useful information seems to be available.
>>>> Can anyone help me with this please.
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To start a new topic, e-mail: users@tomcat.apache.org
>>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>>
>>>>
>>>>
>>> ---------------------------------------------------------------------
>>> To start a new topic, e-mail: users@tomcat.apache.org
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>
> 
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message