tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Wachter <Stefan.Wach...@gmx.de>
Subject Using APR in a Catalina-Home/Base Installation
Date Mon, 03 Jul 2006 13:48:36 GMT
Hi all,

after a while I had figured out how to use APR with Tomcat (cf. 
http://thread.gmane.org/gmane.comp.jakarta.tomcat.user/133360/focus=133360) 
on a 64-Bit environment with a 32-bit JVM. Now the next issue popped up:

If Tomcat is started from the CATALINA_HOME/bin directory by startup.sh 
then the log file CATALINA_HOME/logs/catalina.out clearly informs if APR 
is not used: "The Apache Tomcat Native library which allows optimal 
performance in production environments was not found on the 
java.library.path: ...".

Yet, in an installation with a CATALINA_HOME directory and several 
CATALINA_BASE directories that message does not appear when Tomcat is 
started with different CATALINA_BASE settings. In other word, if the 
CATALINA_BASE environment variable is set to another directory than 
CATALINA_HOME and the CATALINA_HOME/bin/startup.sh is executed then the 
log file CATALINA_BASE/logs/catalina.out does not contain that message. 
(The log file CATALINA_HOME/logs/catalina.out is not written any more.)

1. Why is this message no longer reported?
2. Is there a possibility to check if the APR is used or not?

Cheers,
--Stefan




---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message