tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wall <d.w...@computer.org>
Subject TC 5.5.17 restart ERROR: JDWP Transport dt_socket failed to initialize
Date Thu, 01 Jun 2006 15:57:08 GMT
Since upgradeing from 5.5.12 to 5.5.17, it seems that when I restart 
tomcat, I get an error that didn't occur before.  The error may be 
related to some remote debugging options set when TC is started, yet 
these didn't seem to create an issue before.

Here's the error in catalina.out:

INFO: Stopping Coyote HTTP/1.1 on http-9443
ERROR: transport error 202: bind failed: Address already in use 
["transport.c",L41]
ERROR: JDWP Transport dt_socket failed to initialize, 
TRANSPORT_INIT(510) ["debugInit.c",L497]
JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports 
initializedFATAL ERROR in native method: JDWP No transports initialized, 
jvmtiError=JVMTI_ERROR_INTERNAL(113)
Listening for transport dt_socket at address: 9000

Here's the debug start options we use for tomcat in startup.sh on Linux:

JAVA_OPTS="-server -Xdebug 
-Xrunjdwp:transport=dt_socket,address=9000,server=y,suspend=n -Xms50m 
-Xmx200m -Dmy.custbase=$MY_CUSTOMER_BASE"

Thanks for any ideas.  I even increased the sleep time between the stop 
and the start from 5 seconds to 10 seconds, yet the problem persists, 
and I don't recall it happening at all before.

Thanks,
David

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message