tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Armour David" <>
Subject RE: Trouble with Admin WebApp
Date Fri, 23 Jun 2006 17:04:08 GMT

Thanks for help on the Admin webapp location.  I have moved it to
/server/webapps.  I then restarted Tomcat and it still does not
function. I deployed the admin.xml to conf/Catalina/localhost.  The
manager application shows it running, but when I follow the link I get.

Tomcat's administration web application is no longer installed by
default. Download and install the "admin" package to use it.

The url that I get from the manager application for the admin webapp is:


Ideas to help get this running?  Thanks.

David Armour

Java Application Architect

Winterthur U.S. Holdings, Inc.

-----Original Message-----
From: David Smith [] 
Sent: Friday, June 23, 2006 10:23 AM
To: Tomcat Users List
Subject: Re: Trouble with Admin WebApp

Wrong place to install the admin webapp.  The webapp itself needs to be 
in $CATALINA_HOME/server/webapps right next to the manager webapp.  
admin.xml is correctly placed.


Armour David wrote:

>I am running Windows 2000.  I have installed Tomcat 5.5.17.  I am 
>running Java Version: build 1.5.0_06-b05.
>I ran the Windows executable for the installation.  The default home 
>page comes up.  I have added an administrative account.  The Tomcat 
>Manager web application runs properly.
>I downloaded the admin webapp.  I copied the admin directory under the 
>webapps of the Tomcat install.  I also added the admin.xml to 
>conf/Catalina/localhost directory.
>The logs show the following error:
>Jun 23, 2006 8:43:59 AM org.apache.catalina.core.StandardContext start
>SEVERE: Error in resourceStart()
>Jun 23, 2006 8:43:59 AM org.apache.catalina.core.StandardContext start
>SEVERE: Error getConfigured
>Jun 23, 2006 8:43:59 AM org.apache.catalina.core.StandardContext start
>SEVERE: Context [/admin] startup failed due to previous errors Jun 23, 
>2006 8:43:59 AM org.apache.catalina.core.StandardContext stop
>INFO: Container 
>has not been started
>Jun 23, 2006 8:45:06 AM org.apache.coyote.http11.Http11BaseProtocol
>INFO: Pausing Coyote HTTP/1.1 on http-8080
>Jun 23, 2006 8:45:07 AM org.apache.catalina.core.StandardService stop
>INFO: Stopping service Catalina
>Jun 23, 2006 8:45:07 AM org.apache.coyote.http11.Http11BaseProtocol
>INFO: Stopping Coyote HTTP/1.1 on http-8080
>Jun 23, 2006 8:45:07 AM org.apache.catalina.core.AprLifecycleListener
>INFO: Failed shutdown of Apache Portable Runtime
>Jun 23, 2006 8:45:14 AM org.apache.catalina.core.AprLifecycleListener
>INFO: The Apache Tomcat Native library which allows optimal performance

>in production environments was not found on the java.library.path: 
>Files\Microsoft SQL Server\80\Tools\BINN;C:\Program
>Files\Subversion\bin;C:\Program Files\Microsoft SQL
>C:\Program Files\Altiris\Software Virtualization Agent\;C:\Program
>Files\ActivCard\SecureLogin Single Sign-On\
>Jun 23, 2006 8:45:14 AM org.apache.coyote.http11.Http11BaseProtocol
>INFO: Initializing Coyote HTTP/1.1 on http-8080
>Jun 23, 2006 8:45:14 AM org.apache.catalina.startup.Catalina load
>INFO: Initialization processed in 843 ms
>Jun 23, 2006 8:45:14 AM org.apache.catalina.core.StandardService start
>INFO: Starting service Catalina
>Jun 23, 2006 8:45:14 AM org.apache.catalina.core.StandardEngine start
>INFO: Starting Servlet Engine: Apache Tomcat/5.5.17
>Jun 23, 2006 8:45:14 AM org.apache.catalina.core.StandardHost start
>INFO: XML validation disabled
>SEVERE: Error starting static Resources
>java.lang.IllegalArgumentException: Document base C:\apps\apache\Tomcat
>5.5\server\webapps\admin does not exist or is not a readable directory
>	at
>	at
>	at
>	at
>	at
>	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
>	at java.lang.reflect.Method.invoke(Unknown Source)
>The Manager application shows the admin as deployed but not started. 
>Also, in the Manager application all the other webapps have a live 
>Reload link, while the admin applications Reload link is not enabled. 
>What is wrong here?
>David Armour
>Java Application Architect
>Winterthur U.S. Holdings, Inc.
>To start a new topic, e-mail:
>To unsubscribe, e-mail:
>For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message