tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Williams" <...@csunv.com>
Subject RE: More (Unending) "Resource Not Found"/ Directory Problems
Date Thu, 25 May 2006 22:04:05 GMT
Yeah, I fixed that.  That error is no longer in the logs.

> -----Original Message-----
> From: Jay Burgess [mailto:lists@vtgroup.com]
> Sent: Thursday, May 25, 2006 5:22 PM
> To: users@tomcat.apache.org
> Subject: RE: More (Unending) "Resource Not Found"/ Directory Problems
>
>
> The reason I commented is that I noticed in one of your previous
> posts a log
> error like:
>
> "Document base
> /usr/local/tomcat/webapps/usr/local/tomcat/webapps/smsinfo does
> not exist or is not a readable directory."
>
> Since this message contains the string
> "/usr/local/tomcat/webapps" twice, I
> thought maybe it was concatenating an absolute appBase with an
> absolute docBase,
> when it should be concatenating an absolute appBase with a
> relative docBase.
>
> Can you check the same log and see what the error looks like now?
>
> Jay
>
> | Jay Burgess [Vertical Technology Group]
> | http://www.vtgroup.com/
>
>
> -----Original Message-----
> From: Allen Williams [mailto:anw@csunv.com]
> Sent: Thursday, May 25, 2006 4:03 PM
> To: Tomcat Users List
> Subject: RE: More (Unending) "Resource Not Found"/ Directory Problems
>
> Thanks.  This all started when I went from a Debian package install to
> a more "vanilla" Linux install.  Under the Debian apt package install,
> it put everything into /usr/share/, and everything worked fine until I
> tried to install an Ajp13 connector, whereupon it was recommended I do
> the vanilla install.  I put the vanilla install into /usr/local (seemed
> to make more sense for some reason than /usr/share), and since then my
> (very simple, just to get started) app doesn't work.  As you can see from
> this thread, it's like it can't find the top-level app directory (which,
> of course, I've put under /usr/local/tomcat/webapps).  When I try
> to access
> it, I get a message in my browser that says "The requested resource
> (/smsinfo/) is not available".
>
> Actually, at the moment, I am back to a relative path for docBase.
>
> Is there anyway to set a higher debug level or something so that maybe
> tomcat will print out how he is trying to resolve paths, etc.?
>
> > -----Original Message-----
> > From: Jay Burgess [mailto:lists@vtgroup.com]
> > Sent: Thursday, May 25, 2006 4:53 PM
> > To: users@tomcat.apache.org
> > Subject: RE: More (Unending) "Resource Not Found"/ Directory Problems
> >
> >
> > I'm coming into this discussion late, so ignore this if it's
> > offbase, but it
> > looks like you are using absolute paths for both appBase and docBase:
> >
> > <Host name="localhost" appBase="/usr/local/tomcat/webapps"
> >
> > <Context path="/smsinfo" docBase="/usr/local/tomcat/webapps/smsinfo"
> >
> > The docBase docs say "You may specify an absolute pathname for
> > this directory or
> > WAR file, or a pathname that is relative to the appBase directory
> > of the owning
> > Host."
> >
> > Shouldn't you be using a relative path for docBase, not an absolute one?
> >
> > Jay
> >
> > | Jay Burgess [Vertical Technology Group]
> > | http://www.vtgroup.com/
> >
> > -----Original Message-----
> > From: Allen Williams [mailto:anw@csunv.com]
> > Sent: Thursday, May 25, 2006 3:34 PM
> > To: Tomcat Users List
> > Subject: RE: More (Unending) "Resource Not Found"/ Directory Problems
> >
> > Oooo-kay.  I went and (re)read the document you suggested, did
> > change docbase in the Context element to docBase (which I did
> > miss until you pointed it out), and the same thing still hap-
> > pens.  Evidently, there's no way to tell tomcat how many times
> > I've read the documentation;-)
> >
> > I know this is bound to be some stupid little thing I've missed
> > (I actually had high hopes with the docbase->docBase change),
> > but I don't know what it is.
> >
> > > -----Original Message-----
> > > From: Hassan Schroeder [mailto:hassan.schroeder@gmail.com]
> > > Sent: Thursday, May 25, 2006 4:11 PM
> > > To: Tomcat Users List
> > > Subject: Re: More (Unending) "Resource Not Found"/ Directory Problems
> > >
> > >
> > > On 5/25/06, Allen Williams <anw@csunv.com> wrote:
> > > > Are the absolute paths like
> > > > "http://localhost:8080/smsinfo"
> > > > or like "/usr/local/tomcat/webapps/smsinfo"?
> > >
> > > File system paths, your second choice :-)
> > >
> > > > Also, I assume by docBase you mean the docbase attribute in
> > the Context
> > > > element.
> > >
> > > Sweet mother of -- no, I mean "docBase", which, if you *read* the
> > > Fine Documentation at
> > > <http://tomcat.apache.org/tomcat-5.5-doc/config/context.html>,
> > > you'll see is spelled exactly that way *AND IS CASE SENSITIVE*.
> > >
> > > OK? Go through your configuration and *look closely* at each element
> > > and attribute and *check them against the doc*. It'll save
> you a lot of
> > > unneccessary frustration. Really. :-)
> > >
> > > --
> > > Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
> > >
> > > ---------------------------------------------------------------------
> > > To start a new topic, e-mail: users@tomcat.apache.org
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message