tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject JSSE13SocketFactory in a 1.5 JVM and SUN-SPECIFIC classes
Date Thu, 18 May 2006 17:40:13 GMT

I'm trying to build Tomcat 5.5.15 using the IBM 1.5 JDK.

Why?  Because I'm working with a user that wants to run with the IBM 1.5 
JDK in production.  They want to build Tomcat with the IBM JDK for 2 
reasons:
1)  To ensure that they can build if they have to fix/change something 
(and this is their JDK of choice).
2)  To preempt any potential runtime problems with missing classes in 
the JVM by catching and fixing them at build time rather than runtime.

I'm having problems building JSSE13SocketFactory because of references 
to SUN-SPECIFIC classes in packages like com.sun.net.ssl.internal.ssl.*

Am I correct in understanding that this class only exists for 
compatibility with 1.3 JVMs and will never be executed in a 1.5 JVM?  If 
   so, then that should address #2 above (we'll never execute the class. 
  I could then address #1 by either changing the class or possibly even 
removing it and all references.

Have other folks built Tomcat using JDKs other than Sun's?  How do you 
work around problems like this?

Thanks for the help!
Joe


-- 
Joe Bohn
joe.bohn at earthlink.net

"He is no fool who gives what he cannot keep, to gain what he cannot 
lose."   -- Jim Elliot

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message