tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <fzli...@omnytex.com>
Subject Re: stylesheets giving 404 after a long response time
Date Tue, 09 May 2006 19:05:03 GMT
I'm not sure, it's just one of those things that seems fishy to me... I 
would *logically* think it has nothing to do with it, or at least if it 
did, I definitely would not expect a 404... but I also know that logic 
frequently has nothing to do with solving problems like this :)

If the timeouts are far longer than 20 minutes though (Infinite?  Didn't 
know you could do that actually), then it wouldn't think that's the 
problem.  Even still, 20 minutes for a request, I'd *still* be inclined 
to think that's the root cause of the problem somehow.

Frank

Vivek Mohan wrote:
> Yes, its Tomcat which is serving the resources. And I've made the
> timeouts to be infinity for my application so I don't think timeouts
> would be occurring. But in any case how does a timeout affect the
> fishing out of stylesheets?
> 
> -- 
> Vivek.
> 
> On 5/10/06, Frank W. Zammetti <fzlists@omnytex.com> wrote:
>> A 20 minute response time?  Before I worried about why the stylesheet
>> gets a 404, I'd solve that :)  Trying to hold an HTTP connection open
>> that long is a recipe for all sorts of problem (proxy timeouts, browser
>> timeouts, etc).
>>
>> Is Tomcat serving the stylesheet, i.e., no web server in front of it?
>> I'm wondering if session timeout isn't playing role somehow (not sure
>> how it would, but with a request time that long, not very much would
>> surprise me).
>>
>> Frank
>>
>> Vivek Mohan wrote:
>> > Hi People,
>> >
>> > I've an application running on tomcat 4.1. In one particular request,
>> > I could find that the server response takes a long time, say around 20
>> > minutes, and when the page comes back all the stylesheets and header
>> > jsps are missing from the page. If I check my access logs, I see a 404
>> > response for all the inclusions into the main jsp.
>> >
>> > Can anyone tell me how to solve this issue, or how to go about
>> > investigating it?
>> >
>> > --
>> > Vivek.
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> > For additional commands, e-mail: users-help@tomcat.apache.org
>> >
>> >
>> >
>> >
>>
>> -- 
>> Frank W. Zammetti
>> Founder and Chief Software Architect
>> Omnytex Technologies
>> http://www.omnytex.com
>> AIM: fzammetti
>> Yahoo: fzammetti
>> MSN: fzammetti@hotmail.com
>> Java Web Parts -
>> http://javawebparts.sourceforge.net
>> Supplying the wheel, so you don't have to reinvent it!
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> 

-- 
Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
http://www.omnytex.com
AIM: fzammetti
Yahoo: fzammetti
MSN: fzammetti@hotmail.com
Java Web Parts -
http://javawebparts.sourceforge.net
Supplying the wheel, so you don't have to reinvent it!

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message