tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugh Morgan <hughb...@gmail.com>
Subject Re: Newbie: Deploying .war file, getting it working with MySQL
Date Mon, 08 May 2006 13:22:37 GMT
Franck Borel wrote:
> Where did you place your Realm block?
> 
> It must be placed inside the context block like this:
> 
> <Context ..>
>     <Realm ...../>
> </Context..>

I did not have it here, I had it in the Engine tag.  I have now changed 
it, and stoped and restarted the server.  I still get the same error. 
The relavent bit of my server.xml file looks like this -

     <Engine name="Catalina" defaultHost="localhost">
...
       <!--
       <Realm  className="org.apache.catalina.realm.JDBCRealm"
              driverName="com.mysql.jdbc.Driver"
           connectionURL="jdbc:mysql://localhost/authority"
          connectionName="root" connectionPassword="ROOT_PASSWORD"
               userTable="users" userNameCol="user_name" 
userCredCol="user_pass"
           userRoleTable="user_roles" roleNameCol="role_name" />
       -->
...
       <Host name="localhost" appBase="webapps"
        unpackWARs="true" autoDeploy="true"
        xmlValidation="false" xmlNamespaceAware="false">
         <Context path="/minimal" docBase="minimal" debug="0"
                 reloadable="false" crossContext="true">
           <Realm  className="org.apache.catalina.realm.JDBCRealm"
                   driverName="com.mysql.jdbc.Driver"
                   connectionURL="jdbc:mysql://localhost/authority"
                   connectionName="root" connectionPassword="ROOT_PASSWORD"
                   userTable="users" userNameCol="user_name" 
userCredCol="user_pass"
                   userRoleTable="user_roles" roleNameCol="role_name" />
         </Context>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message