tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: NoClassDefFoundError: javax/servlet/http/HttpServlet
Date Tue, 02 May 2006 17:07:32 GMT
it should work without that setting assuming that tomcat picks up the 
file setclasspath.sh correctly,
the reason I mentioned it is cause the sunVM doesn't have a 
gnu.java.lang.MainThread class, so I would suspect that you are not 
running the VM you think you are running. Of course, I know very little 
about OS-X, but that is where I would recommend you to start looking

Filip


Edoardo Panfili wrote:
> Edoardo Panfili wrote:
>> Filip Hanik - Dev Lists wrote:
>>> if you are running the Sun VM, why is this in your stack trace?
>>>
>>> at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
>> The stack is the one that Tomcat has print before the "remove" of gcj.
>>
>> But the error is still here also after the "remove".
>>
>>
>>> my guess is that you forgot to do this
>>>
>>> export PATH=$JAVA_HOME/bin:$PATH
>>> in catalina.sh
>> yes, i forgot this.
>> But, sorry for the question, is it possible that this error causes my 
>> problems?
>
> PS: I have an OS X 10.3 machine running from 2004 without this setting.
>
> thanks again
> Edoardo
> -- 
> edoardo@aspix.it
> AIM: edoardopn
> Jabber: edoardopa@talk.google.com
> tel:075 9142766
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message