tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: NoClassDefFoundError: javax/servlet/http/HttpServlet
Date Tue, 02 May 2006 16:14:04 GMT
try running a different VM, like the Sun VM, this could be a bug in the 
VM you are running.

Filip

Edoardo Panfili wrote:
> Edoardo Panfili wrote:
>> Marc Farrow wrote:
>> there is somethings wrog in my develope/deploy/me system.
>> I'll begin from scratch.
> After a fresh installation the problem is still here (but not after 
> all restarts).
>
> sometimes Tocat throws this exception
> java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
>         at java.lang.ClassLoader.defineClass1(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
> atjava.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
>
> but this not happens all the times, after a restart Tomcat now works 
> correctly. I can't figure why.
>
> In the original situation I have also another VM installed (I didn't 
> know) but I have removed libgcj6 and all the dipendencies.
>
> In catalina.log I can find:
> ====================================================
> Exception in thread "main" java.lang.NoClassDefFoundError: while 
> resolving class: org.apache.catalina.startup.Bootstrap
>    at java.lang.VMClassLoader.transformException(java.lang.Class, 
> java.lang.Throwable) (/usr/lib/libgcj.so.6.0.0)
>    at java.lang.VMClassLoader.resolveClass(java.lang.Class) 
> (/usr/lib/libgcj.so.6.0.0)
>    at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
>    at java.lang.Class.forName(java.lang.String, boolean, 
> java.lang.ClassLoader) (/usr/lib/libgcj.so.6.0.0)
>    at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
> Caused by: java.lang.ClassNotFoundException: 
> javax.management.ObjectName not found in 
> gnu.gcj.runtime.SystemClassLoader{urls=[file:./,file:/opt/tomcat/bin/bootstrap.jar,file:/

>
> opt/tomcat/bin/commons-logging-api.jar], 
> parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
>    at java.net.URLClassLoader.findClass(java.lang.String) 
> (/usr/lib/libgcj.so.6.0.0)
>    at java.lang.ClassLoader.loadClass(java.lang.String, boolean) 
> (/usr/lib/libgcj.so.6.0.0)
>    at java.lang.ClassLoader.loadClass(java.lang.String) 
> (/usr/lib/libgcj.so.6.0.0)
>    ...4 more
> =====================================================
> but now libgcj.so is no longer in my system
>
> The first line of catalina.sh is
> export JAVA_HOME=/opt/jdk
>
> Tomcats starts up with no problems.
> my libc version is 2.3.6
> kernel version is 2.6.15
> and the Sun JVM is 1.5.0_06
>
> Now the system works but I don't know why.
>
> thanks
> Edoardo Panfili
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message