tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Smith <quick...@yahoo.com>
Subject Re: stop and start an application
Date Sat, 20 May 2006 00:26:15 GMT
For my case, I do not use war. I exported jar files
directly to WEB-INF/lib. But it is not pick up when I
re-started Tomcat. I have to re-start Tomcat a couple
of times for it to be used.

Tony

--- Calvin  Deiterich <cedeiter@hacc.edu> wrote:

> This seems to be similar to a post that got started
> under another
> thread.  I have included the info below.
> What I have found so far is that the complete tree
> does not get
> transfered to the Tomcat webapps folder from the
> .war.
> I have to do some testing to see if I can come up
> with exactly what it
> happening.
> Calvin
> 
> 
> >>> Ingo.Bischofs@toshibatec-tgis.com 5/19/2006
> 3:36:39 AM >>>
> Hi list
> 
> As i am a newbie to tomcat this question might be
> easy to answer for
> you:
> 
> I have succesfully deployed a .war application with
> eclipse wtp. 
> Installing that .war file to tomcat works fine,
> but...
> 
> After stopping the application and starting it
> again, tomcat comes up
> with 
> errors telling me there is a null pointer exception.
> Does anyone have an idea why?
> 
> Thanks
> 
> Tony,
> I have the same problem. Eclipse 3.1 WTP install.
> I ended up shutting down tomcat and deleting the
> .war and the folder,
> then saving the new .war file and start the tomcat
> up again.
> I also publish to another tomcat server and still
> have to do the same
> thing.  On both machines I am running tomcat 5.5.17.
> Hope someone has a solution as this is a pain.
> Calvin
> 
> Tony Smith wrote the following on 5/18/2006 7:30 PM:
> > Hi, 
> >  
> >  I am using Tomcat 5.5.9 on Windows. I use Eclipse
> to
> >  write my server code. Every time I change my
> code, I
> >  export the jar directly to the myapp/WEB-INF/lib
> >  directory and restart Tomcat. I found that the
> new
> >  code is not immediately used by Tomcat, I have to
> >  re-export, re-start Tomcat a couple times to make
> >  Tomcat pickup my new code.
> >  
> >  Anyone know why?
> >  
> >  Thanks,
> >  
> >  qq
> >>
> >> _
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail:
> users-help@tomcat.apache.org
> 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message