tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darren Hall" <dh...@utrs.com>
Subject Default install of Tomcat not working properly
Date Mon, 08 May 2006 19:03:34 GMT
I'm having a problem getting tomcat 5.5.17 running on Solaris 10. I
preformed a default install of all the binary files and set my JAVA_HOME
variable to my install of jdk1.5  (/opt/jdk1.5/)

The problem I am running into is when I try to view my servlets-examples
page I get a 404 error from tomcat saying it can't find the resource.

When I click on the JSP examples the page appears but none of my JSP
examples function properly. I get an exception error as follows.

javax.servlet.ServletException: Wrapper cannot find servlet class
org.apache.jsp.jsp2.el.basic_002darithmetic_jsp or a class it depends on
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase
.java:432)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:684)
java.lang.Thread.run(Thread.java:595)
root cause 
java.lang.ClassNotFoundException:
org.apache.jsp.jsp2.el.basic_002darithmetic_jsp
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.jav
a:1352)
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.jav
a:1198)
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase
.java:432)
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:684)
java.lang.Thread.run(Thread.java:595)

Let me know if anyone has run into this. Thanks.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message