tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Tomcat 3.2.1 + JDK 1.4
Date Mon, 10 Apr 2006 04:05:14 GMT
Even by Tomcat's very liberal standards, you are asking about a version that 
has been officially unsupported in over five years ;-).  If you are really 
lucky, there may be a grey-beard out here that remembers that far back (but, 
I'm not that old :).  Otherwise, it's probably time to consider upgrading to 
at least 3.3.2.

Tomcat 3.2.x is prettly heavly coded against JSSE 1.0.0.  The JSSE 1.0.1 
that ships with JDK 1.4 isn't really compatible, especially when it comes to 
dealing with client-certs.  Since there will never be another 3.2.x release, 
your options are to either upgrade Tomcat to at least 3.3.2 or downgrade 
your JVM to 1.3.x.

"Sandeep N" <snair1020@yahoo.com> wrote in message 
news:20060410022756.60122.qmail@web54206.mail.yahoo.com...
>  I am getting error messages on the console when a https page is  invoked. 
> The error messages starts coming on the console immediately  when the 
> certificate dialog appears.If we do not respond to the  certificate dialog 
> box, error messages will continue to appear on the  console and finally 
> causing stack overflow.      Following are the error messages appearing on 
> the console:
>    Ctx(  ): 400 R( /) null
>  2006-04-07 04:54:40 - Ctx(  ): IOException in: R( /) Connection closed by 
> remote host
>  2006-04-07 04:54:40 - Ctx(  ): IllegalStateException in: R( /) Current 
> state = FLUSHED, new state = CODING
>  2006-04-07 04:54:40 - Ctx(  ): IllegalStateException in: R( /) Current 
> state = FLUSHED, new state = CODING
>  2006-04-07 04:54:40 - Ctx(  ): IllegalStateException in: R( /) Current 
> state = FLUSHED, new state = CODING
>  .
>  .
>  .
>  2006-04-07 04:54:53 - Ctx(  ): IllegalStateException in: R( /) Current 
> state = FLUSHED, new state = CODING
>  2006-04-07 04:54:53 - Ctx(  ): Exception in: R( /) - 
> java.lang.StackOverflowError   at 
> sun.security.action.GetPropertyAction.run(GetPropertyAction.java:66)
>   at java.security.AccessController.doPrivileged(Native Method)   at 
> java.io.PrintWriter.<init>(PrintWriter.java:72)
>   at java.io.PrintWriter.<init>(PrintWriter.java:57)
>   at 
> org.apache.tomcat.context.ExceptionHandler.doService(DefaultCMSetter.java:268)
>   at org.apache.tomcat.core.Handler.service(Handler.java:286)
>   at 
> org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
>   at 
> org.apache.tomcat.core.ContextManager.handleError(ContextManager.java:1147)
>   at org.apache.tomcat.core.Handler.service(Handler.java:311)
>   at 
> org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
>   at 
> org.apache.tomcat.core.ContextManager.handleError(ContextManager.java:1147)
>
>    Please advise.
>
>
>  Thanks
>  Sandeep.
>
>
>
> ---------------------------------
> New Yahoo! Messenger with Voice. Call regular phones from your PC and save 
> big. 




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message