tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Leone <midnightj...@verizon.net>
Subject Re: Can't authenticate to admin, tried everything
Date Sun, 30 Apr 2006 12:38:52 GMT
Mark Leone wrote:
> I have tomcat 5.5.17 and I recently downloaded the admin web app. I 
> can't seem to find a way to authenticate to it. I have an existing 
> JDBCRealm that works fine with the manager web app, using digested 
> passwords. I added a user with a non-digested password, since admin 
> uses FORM authentication, but I still get authenticate failures.
>
Well, I guess I didn't try as much as I thought I did. I was confusing 
DIGEST authentication with digested passwords, though I know better. I 
was entering the cleartext password in the Realm database, instead of 
the digested version of the cleartext password. Now it works. However, I 
still don't know why the UserDatabaseRealm didn't work, since that realm 
doesn't use digested passwords. But that was only for test purposes anyway.

-Mark




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message