tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <tomcat-u...@kippdata.de>
Subject Re: Performance issue with Tomcat 5.0
Date Thu, 13 Apr 2006 08:46:57 GMT
Use the tool of your choice (depending on your platform) to find out, 
which threads are using the cpu time. The do a Java Thread Dump and have 
a look at it.

For *nix use ps (or prstat on Solaris) to find out about the threads. 
Use kill -QUIT to write a thread dump to STDOUT (which you should 
redirect when starting the Java process).

In the Thread Dump each thread has a nid=0xSOME_HEX_NUMBER and at least 
on Solaris this SOME_HEX_NUMBER is the thread number in hexadecimal.

opensta wrote:
> In our application , jboss app server , fiorano messaging server , Tomcat 5.0
> webserver ,
> 
> first time when give load of 200 users it works fine ,
> but after some time 10 min , the tomcat server remains 48% idle , when there
> is no load , 
> 
> when i type top command it shows java process taking 99 % cpu , 
> 
> where is issue , how to resolve it ,
> 
> in application , applets are running at client side ? is that due to applet
> , 
> 
> how i should debug
> --
> View this message in context: http://www.nabble.com/Performance-issue-with-Tomcat-5.0-t1442675.html#a3895859
> Sent from the Tomcat - User forum at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message