tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: [REPOST] Tomcat 5.5.15 - HTTPS hanging and intermittent "Page Cannot be Displayed" problems
Date Mon, 03 Apr 2006 18:18:16 GMT
When I said change log, I meant the text file that lists out all the
changes the developers made between releases.  What issues they fixed
and what not.  Is your install using the APR native library that I
believe was introduced somewhere around 5.5.15?

--David

Richard Mundell wrote:

>Hi David,
>
>There's nothing in any of the log indicating any problems.
>
>We uninstalled Tomcat 5.5.15 on the server and installed 5.5.9 with
>identical configuration (with the exception of reconfiguring the HTTPS
>connector to use the Java Key Store rather than OpenSSL-style certificate
>and key). No other response time issues with other servers hosted on the
>network (which use the same internet connection and firewalls/routers).
>
>Puzzling huh? ;-)
>
>- Richard
>
>-----Original Message-----
>From: David Smith [mailto:dns4@cornell.edu] 
>Sent: Monday, April 03, 2006 2:09 PM
>To: Tomcat Users List
>Subject: Re: [REPOST] Tomcat 5.5.15 - HTTPS hanging and intermittent "Page
>Cannot be Displayed" problems
>
>Given you've indicated all the headaches occurred in the move from 5.5.9 to
>5.5.15, you might want to take a look at the change log in relation to your
>environment.  Are your connectors configured the same (acceptCount,
>maxThreads)?
>
>Beyond that, issue 1 implies something else may be causing issues on the
>network and interfering with your server's operation -- especially when you
>can't reproduce it at any other time.  Maybe something is causing high
>traffic to the point of denial of service.  Do any other services have
>issues with dropped connection or delayed response during the same time?
>
>--David
>
>Richard Mundell wrote:
>
>  
>
>>Apologies for the repost but I sent this last week but didn't get any 
>>replies. In the hope that the people with the answers on this might've 
>>missed it, I'm trying again... ;-)
>>
>> _____
>>
>>From: Richard Mundell [mailto:richard.mundell@trgrp.com]
>>Sent: Friday, March 31, 2006 11:33 AM
>>To: 'users@tomcat.apache.org'
>>Subject: Tomcat 5.5.15 - HTTPS hanging and intermittent "Page Cannot be 
>>Displayed" problems
>>
>>
>>We upgraded our internet-facing web server from Tomcat 5.5.9 to 5.5.15 
>>this weekend and have run into a number of intermittent connectivity 
>>problems which have resulted in rolling back to 5.5.9.
>>
>>We use the Tomcat HTTPS connector (without an intermediate web server 
>>between the clients and Tomcat) with all of the default configuration.
>>
>>Issue 1: A couple of our clients have experienced intermittent 
>>connectivity problems (where approximately 1 out of every 20 page loads 
>>results in an immediate "Page Cannot Be Displayed" error in Internet 
>>Explorer - it appears that Tomcat immediately rejects the connection).
>>
>>Issue 2: Also, during peak loading (although we're only talking about 
>>30 to 40 concurrent users here) Tomcat appears to hang for a while and 
>>make new connections wait for up to 1 minute before returning a page.
>>
>>Throughout this time processor load has been consistently < 20%. (The 
>>server is a dual Xeon processor, dual core machine, running Windows 2003
>>    
>>
>Server).
>  
>
>>The first problem we've seen before when we used to use Apache (with 
>>the JK
>>connector) to deliver the HTTPS pages - I suspect the compatibility 
>>with Apache/OpenSSL's implementation of SSL and Internet Explorer's 
>>implementation of SSL are still slightly incompatible. (I believe this 
>>is a known issue on a Windows platform but has never been resolved). 
>>The second problem (with Tomcat not responding to new HTTPS requests 
>>quickly under moderate load) is new on me.
>>
>>I'm not really able to submit this as a bug to the Tomcat team as 
>>out-of-hours we've been unable to recreate this (even simulating a high 
>>load using JMeter), and the "Page Cannot Be Displayed" issue only 
>>occurs with certain brands of proxy server (Secure Computing's Sidewinder
>>    
>>
>seems
>  
>
>>particuiarly sensitive to this). Also, there's no errors   
>>
>>The only conclusion I can draw right now is that if you want to use 
>>Tomcat to deliver HTTPS content from a Windows-based server, stick with 
>>Tomcat 5.5.9.
>>
>>Has anyone else had a similar experience?
>>
>>Richard
>>___________________________
>>Richard Mundell
>>The Roberts Group
>>Market Data Expertise that FITS.
>>+1 212 499 2680 x20 (office)
>>www.trgrp.com
>>
>> 
>>
>>    
>>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>For additional commands, e-mail: users-help@tomcat.apache.org
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message