tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Schönhaber <mailing-tomcat-u...@schoenhaber.de>
Subject Re: tools.jar not in CP (Tomcat 5.5.15)
Date Sun, 02 Apr 2006 20:26:39 GMT
Martin Schulz wrote:
> My webapps needs to access the javac compiler classes from tools.jar.
>
> This appears to work on dev environment on Windows, but it doesn't
> in a deployment environment:
> Solaris 9
> JDK 1.5.0_06
>
> The app hits a java.lang.ClassNotFoundException: com.sun.tools.javac.Main
>
> According to the documentation, tools.jar should always be in the
> class path:
> http://tomcat.apache.org/tomcat-5.5-doc/class-loader-howto.html

If I insert an
echo $CLASSPATH
into catalina.sh on Linux, I see that tools.jar isn't included. Maybe the docs 
are not right (anymore?).

> Looking at the startup scripts (I think I saw it in the doumentation too
> somewhere) there is a 'javac' option (in catalina.sh), which appears
> to be in some state of disrepair.  At least the order of arguments
> passed from startup.sh does not match how catalina.sh looks at the args,
> nor does catalina.sh actually consume the 'javac', or evaluate it
> as a valid command.
>
> I guess I'm confused at this stage as to what to believe and how to
> proceed.

How about copying tools.jar to commons/lib?

Regards
  mks

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message