tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M. Schot" <marcel.sc...@gmail.com>
Subject Tomcat 5.0.28 Sending content that does not match the URL
Date Tue, 14 Feb 2006 14:00:18 GMT
Hi All,

I am experiencing strange problems with Tomcat 5.0.28. The problem is that
sometimes (1 out of 10) when I load a JSP Tomcat seems to send the wrong
stylesheets for a certain url. This problem occurs when serving them using a
servlet and a CMS but also if they are located on the harddrive and accessed
directly by tomcat.

I am using a server with an Intel Xeon 3.20 Ghz and 4GB of ram on Windows
Server 2003 hyperthreading is enabled. I have used Fiddler to see what goes
on when I request a page. Each page has about 10 stylesheets attached. When
the problem occurs, the page looks like crap in the browser, inspecting it
using Fiddler I can see that there is at least one css file (it might be
coincidence that it goes wrong with a stylesheet) that contains the content
of the next one that was requested.

So the content of the next item that was requested is the same as the one
requested before that. For example the layout.css might contain the actual
content of the main_content.css if the layout.css was requested before the
main_content.css. This behaviour occurs when serving the content using a
third party servlet (Mediasurface binary servlet) or serving it using
Tomcat.

Does anyone have an idea how I can prevent this from happening or what might
be wrong?

Kind regards,

Marcel Schot

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message