tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Letícia Álvares Barbalho <leticia.barba...@gmail.com>
Subject Problem with Tomcat and Java versions
Date Thu, 09 Feb 2006 13:16:12 GMT
Hello everyone,

I was using java 1.4.2 here, and recently migrated to java 1.5.
Unfortunately, something probably is missing, 'cause I'm having problems
with Tomcat.

When I turn on the computer (that has tomcat on it), if I open the browser
and try to access a web application built on java 1.5, it will give me the
famous struts error: "Cannot find ActionMappings or ActionFormBeans
collection". However, if I open a web app built on java 1.4.2, everything
works fine.
Then, if I just restart the tomcat server (with the command /etc/init.d/tomcat
5 restart) and try to access the first application (the one built on java
1.5), everything will work fine.

I'm guessing it's because there's maybe an environment variable that I may
have forgotten to update or something. Here go my variables:

JAVA_HOME = /usr/local/jdk1.5.0_06
PATH = /usr/sbin:/bin:/usr/bin:/sbin:/usr/X11R6/bin

CLASSPATH is empty, my jar's are on the application's lib folder.

Is there something else I should have setted? Is there something I gotta set
in tomcat to show it what java version to use?

I use Tomcat 5 and my server runs on a Suse Linux 9.3 box.

Thanks everyone


--
Letícia Álvares Barbalho
leticia.barbalho@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message