tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William.Ad...@dot.state.fl.us
Subject NoClassDefFoundError in SystemLogHandler during Bootstrap in binary version of TOMCAT 5.5.15
Date Mon, 20 Feb 2006 19:08:05 GMT
Greetings:

I am attempting to run the binary version of  TOMCAT-5.5.15 in
compatibility mode with a 1.4.2 JVM.
It is abending at initialization with the following messages in STDERR.

[Signaling in VM: java/lang/NoClassDefFoundError, message:
org/apache/tomcat/util/log/SystemLogHandler]
      at java.lang.Class.getDeclaredConstructors0(Native Method)
      at java.lang.Class.privateGetDeclaredConstructors(Class.java:1747)
      at java.lang.Class.getConstructor1(Class.java:2063)
      at java.lang.Class.newInstance3(Class.java:331)
      at java.lang.Class.newInstance(Class.java:305)
      at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:205)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:390)

This appears in STDOUT.

 Created MBeanServer with ID: 623d8549:10988bb6472:-8000:MVSTEST:1

This is the CLASSPATH.

06:31:49 JZOSVM50(I):
CLASSPATH=/usr/lpp/java/J1.4/lib/tools.jar:/usr/lpp/tomcat/bin/bootstrap.jar:/usr/lpp/jzos/jzos.jar:

The identical problem occurs with TOMCAT-5.0.28 and 5.0.30 absent
compatibility mode without the niceties in STDOUT.

This is being executed by a ZOS/mainframe layered emulation protocol which
is reasonably flexible
in creating the shell environment for TOMCAT.

I see this particular error has happened in the past on UN*X systems but
I'm not clear as to why.
Can anyone enlighten me?

Thanks,

Bill


William L Adams lll
Systems Programmer lll
DOT
850-414-4235


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message