tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: Tomcat 5.5.15 Clustering ?
Date Wed, 15 Feb 2006 16:08:19 GMT
David, you are all over the place. Slow down for a second.
my guess is that one of your interfaces is not doing what you think it 
is doing.

follow these simple steps

1. Make sure that your multicast is working
2. Stop all your tomcat processes
3. Make sure nothing else is broadcasting on the same mcast address
4. Delete or archive all your previous logs
5. Startup tomcat 1 - wait 10 seconds
6. Startup tomcat 2

Then do the following
7. Set tcpListenAddress="auto" in your server.xml file
8. Repeat steps 1 through 6

9. email the logs to the list

our guess is that you have a networking problem, but you just don't dont 
look into it close enough for yourself and then provide us with the info.

Filip




David Avenante wrote:
> Yes all right !
>
> INFO: Register manager /cluster-1.0-SNAPSHOT to cluster element Host with
> name localhost
> Feb 15, 2006 10:47:32 AM org.apache.catalina.cluster.session.DeltaManagerstart
>
> But Why !!!!
> my mcastAddress is good !!!!!
>
> now i' ve a new error
>
> Feb 15, 2006 10:50:41 AM
> org.apache.catalina.cluster.tcp.FastAsyncSocketSender$FastQueueThreadpushQueuedMessages
> WARNING: Unable to asynchronously send session with id=[GET-ALL-/cluster-
> 1.0-SNAPSHOT] - message will be ignored.
> java.net.ConnectException: Connection timed out
>         at java.net.PlainSocketImpl.socketConnect(Native Method)
>
> but it's a big progress ;)
>
> I got to verifiy if my ntp synchronisation between my server is OK ;)
>
> Thank you very much.
>
>
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message