tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Sabroff <mike.sabr...@cygnusb2b.com>
Subject Re: Problem with Tomcat and Java versions
Date Fri, 10 Feb 2006 15:15:53 GMT
I have been looking at this for a couple of days, and it seems that 
maybe, it is a problem with the init.d startup. Sounds like it is 
pointing at the old tomcat and not the new until you run it manually and 
tell it tomcat 5. I am no systems person and I have many problems of 
this nature and it usually ends up being some file or symlink the I 
failed to remove or change with the new installation.

Letícia Álvares Barbalho wrote:
> I think I could require that, but as a last try - if nothing else would
> work...
>
> But I really think this should be able to be solved without reinstalling.
> The thing is that when I only restart tomcat (with /etc/init.d/tomcat5
> restart) things start working fine! So i don't think it's a tomcat problem,
> but a tomcat configuration problem. It means that maybe, even if
> reinstalling it, it would remain.
>
> On 2/10/06, Anoop kumar V <anoopkumarv@gmail.com> wrote:
>   
>> Do you have the option of reinstalling Tomcat5  - so that Tomcat5 would
>> just
>> pick up java 5 and not have anything at all to do with java 1.4??
>>
>> -Anoop
>>
>> On 2/9/06, Let?cia ?lvares Barbalho <leticia.barbalho@gmail.com> wrote:
>>     
>>> Hey,
>>>
>>> First of all thank you very much for the attention. I got some reading
>>> about
>>> it and found the jars [jaxp_parser_impl].jar and [xml-commons-apis].jar
>>> under /usr/share/tomcat5/common/endorsed
>>> I renamed them (so they could not be found) and restarted the server
>>>       
>> (the
>>     
>>> computer, I mean). Still, didn't work.
>>>
>>> The problem remains just as it was before :(
>>>
>>>
>>>
>>> On 2/9/06, Caldarale, Charles R <Chuck.Caldarale@unisys.com> wrote:
>>>       
>>>>> From: Let?cia ?lvares Barbalho [mailto:leticia.barbalho@gmail.com]
>>>>> Subject: Problem with Tomcat and Java versions
>>>>>
>>>>> I was using java 1.4.2 here, and recently migrated to java 1.5.
>>>>> Unfortunately, something probably is missing, 'cause I'm
>>>>> having problems with Tomcat.
>>>>>           
>>>> You don't say what Tomcat version you're using.  If you were running
>>>>         
>>> 5.5.xon JRE
>>>       
>>>> 1.4.2, there may in fact be something extra, not something
>>>>         
>> missing.  The
>>     
>>>> compatibility package that's required for 1.4.2 execution should be
>>>> removed when using JRE 5; the package consists of two jars in
>>>> common/endorsed, and these should be deleted.  Of course, this may or
>>>>         
>>> may
>>>       
>>>> not have anything to do with your problem, but it's something to try.
>>>>
>>>> - Chuck
>>>>
>>>>
>>>> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE
>>>>         
>> PROPRIETARY
>>     
>>>> MATERIAL and is thus for use only by the intended recipient. If you
>>>>         
>>> received
>>>       
>>>> this in error, please contact the sender and delete the e-mail and its
>>>> attachments from all computers.
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>>
>>>>
>>>>         
>>> --
>>> Let?cia ?lvares Barbalho
>>> leticia.barbalho@gmail.com
>>>
>>>
>>>       
>> --
>> Thanks and best regards,
>> Anoop
>>
>>
>>     
>
>
> --
> Let?cia ?lvares Barbalho
> leticia.barbalho@gmail.com
>
>   

-- 
Mike Sabroff
Web Services
Developer
mike.sabroff@cygnusb2b.com
920-568-8379


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message