tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Sabroff <mike.sabr...@cygnusb2b.com>
Subject Re: Problem with setting up an SSL secure page
Date Wed, 08 Feb 2006 16:13:08 GMT

What firewall are you using..if any? Is it on or off?

Parsons Technical Services wrote:
> What is in the logs?
>
>
>
> ----- Original Message ----- From: "Mark Whitby" <ug82msw@cs.bham.ac.uk>
> To: <users@tomcat.apache.org>
> Sent: Wednesday, February 08, 2006 11:02 AM
> Subject: Problem with setting up an SSL secure page
>
>
> Dear all,
>
> I am currently designing a final year project for my University course 
> and I am having problems getting a working SSL connection.  I have 
> Tomcat set up and working fine, but when it comes to accessing a page 
> over the https setup, I am having no luck.
>
> Firstly a few technical details.  I am using Windows XP Home, with 
> Internet Explorer 6.0.2900.2180.  I am using the latest Java 
> installation, jdk 1.5.0_05 and so the JSSE comes installed with that.  
> I'm using Tomcat 5.0, the latest installation available (it's only 
> been installed on my system for the last few weeks).  I have McAffe 
> Security Centre installed but the problem occurs even with this turned 
> off.
>
> Now the problem.  I have followed word by word the set up instructions 
> in the Tomcat manual.  I have created the certificate and verified it 
> using the command line.  I have altered the server.xml file to include 
> the path "keystorePath="D:/FYPCode/keystore" "where I have copied the 
> keystore to. I've done everything.  Yet when I type 
> https://localhost:8443 in the browser window I get nothing.  When 
> using IE it takes ages to search for the page, then eventually I get 
> "This page cannot be displayed" and in Mozilla I get a message after a 
> couple of minutes saying the page has timed out and get left with a 
> blank page.  So I can't load the page up at all.
>
> I've tried everything I can think of to get it to work.  I have 3 
> different books on this subject and I've followed the instructions in 
> every one to try and get this to work.  Nothing has worked.  I did a 
> Google search using as many different combinations of words I can 
> think of but the only help I get is for Tomcat 3 and the old JSSE 
> installation.  So I'm lost.  I did even think about installing the 
> JSSE 1.3 to see if that had an effect, as I can't find any of the jar 
> files that are mentionned in that area.  However, I felt it best to 
> ignore that as it says.
>
> So as you can see I've tried everything I can think of.  Nothing as 
> worked. If anyone can help me I would be extremely grateful.
>
> Many thanks
>
> Mark Whitby
> ug82msw@cs.bham.ac.uk
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>

-- 
Mike Sabroff
Web Services
Developer
mike.sabroff@cygnusb2b.com
920-568-8379


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message