tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Biernesser, Beth" <Beth.Biernes...@fnf.com>
Subject RE: Multiple services in single Tomcat instance
Date Tue, 21 Feb 2006 15:26:30 GMT
I am also interested in this issue ... I am setting up the same
situation.  If anyone has information, could they also include me in the
reply?  Thanks so much! 

-----Original Message-----
From: Antti Ollilainen [mailto:antti.ollilainen@gmail.com] 
Sent: Tuesday, February 21, 2006 10:24 AM
To: users@tomcat.apache.org
Subject: Multiple services in single Tomcat instance

Hello,

I'm configuring a single Tomcat instance to serve two separate web
applications. The applications are on separate ports and one is accessed
over HTTP while the other one over HTTPS. I managed to get the webapps
configured so that each is its own Service in the server.xml. Actually
there was a discussion about this in last April with the same subject
and I got the tip to use the same name for Engine and Host inside the
Service.

However, I have another problem now: When I start the server, both web
applications seem to start twice. It seems that all application threads
which are initially started are duplicated because both applications log
twice their startup info. I'm using log4j for logging and it seems that
the log lines are not simply duplicated but they originate from separate
threads.

Has anyone experience from this kind of configuration or encountered the
same problem?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message