tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lian Liming <lianlim...@gmail.com>
Subject Question about deployment of web app
Date Tue, 14 Feb 2006 08:13:14 GMT
Hi, all

I am using Tomcat 5.5.15 on Window 2000 server. My web app worked well
before reinstallation of Window2000. After reinstallation, I set up the same
java environment with the same tomcat version. But a problem comes in the
deployment of my former well-working app.

In the tomcat log, I got the following message:
2006-2-14 15:57:47 org.apache.catalina.startup.HostConfig deployDescriptor
Error deploying configuration descriptor myApp.xml
java.lang.NullPointerException
    at org.apache.catalina.startup.HostConfig.deployDescriptor(
HostConfig.java:576)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java
:493)
    at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1195)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.commons.modeler.BaseModelMBean.invoke(BaseModelMBean.java
:503)
    at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(
DynamicMetaDataImpl.java:213)
    at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)
    at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(
DefaultMBeanServerInterceptor.java:815)
    at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java
:784)
    at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java
:1377)
    at org.apache.catalina.manager.ManagerServlet.deploy(ManagerServlet.java
:814)
    at org.apache.catalina.manager.HTMLManagerServlet.deployInternal(
HTMLManagerServlet.java:248)
    at org.apache.catalina.manager.HTMLManagerServlet.doGet(
HTMLManagerServlet.java:95)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(
ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invoke(
StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invoke(
StandardContextValve.java:178)
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
AuthenticatorBase.java:524)
    at org.apache.catalina.core.StandardHostValve.invoke(
StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke(
ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invoke(
StandardEngineValve.java:107)
    at org.apache.catalina.connector.CoyoteAdapter.service(
CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
:869)
    at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection
(Http11BaseProtocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(
PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(
LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(
ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
2006-2-14 15:57:47 org.apache.catalina.startup.ContextConfigapplicationWebConfig
Message: Missing application web.xml, using defaults only
StandardEngine[Catalina].StandardHost[localhost].StandardContext[/myApp]

It is really strange since I didn't change any codes in my web app including
web.xml under WEB-INF. It worked well before the reinstallation, but fail to
deploy after the reinstallation. What is the possible wrong?

My web.xml is attached. Thanks for any suggestions.

Mime
View raw message