tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Delhommois <vinc....@voila.fr>
Subject RE: LoginModule JAAS and Tomcat (initialize method is not called)
Date Wed, 15 Feb 2006 19:35:00 GMT
Thanks for your answer.
You are right.I tried several positions. I'm sure that the conf file is used.
In my conf file :
MyLoginModule {
com.gcatrans.testappli.MyLoginModule required debug=true app=testAppli;
};
I don't know where is made the mapping between the realm name and the conf file...





> Message du 15/02/06 à 19h29
> De : "Caldarale, Charles R" 
> A : "Tomcat Users List" , vinc.del@voila.fr
> Copie à : 
> Objet : RE: LoginModule JAAS and Tomcat (initialize method is not called)
> 
> > From: Vincent Delhommois [mailto:vinc.del@voila.fr] 
> > Subject: Re: LoginModule JAAS and Tomcat (initialize method 
> > is not called)
> > 
> > I start Tomcat with the following option :
> > set 
> > JVM_OPTS=-Djava.security.auth.login.config=D:/Appl/eclipse/wor
> > kspace2/testAppli/jaas.conf (in the catalina.bat)
> 
> Do you mean JAVA_OPTS? JVM_OPTS is not used in the distributed scripts,
> unless you've modified them.
> 
> - Chuck
> 
> 
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you
> received this in error, please contact the sender and delete the e-mail
> and its attachments from all computers.
> 
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message