tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Hamer" <p...@tohave.nl>
Subject RE: Small connection problems with JK 1.2.15 and IIS 5
Date Wed, 08 Feb 2006 12:29:21 GMT
Sorry, I just noticed I forgot a piece of the error :)
The errors I'm still having are almost always immediately preceeded by this
one:

[Wed Feb 08 13:27:53 2006] [error] jk_isapi_plugin.c (549):
HSE_REQ_SEND_RESPONSE_HEADER failed

Tanx,
Paul Hamer

> -----Original Message-----
> From: Paul Hamer [mailto:paul@tohave.nl] 
> Sent: Wednesday, 08 February, 2006 13:23
> To: users@tomcat.apache.org
> Subject: RE: Small connection problems with JK 1.2.15 and IIS 5
> 
> Hi,
> 
> I experienced the same problem as described earlier in this 
> thread. I'm also
> using Tomcat 5.5 (5.5.15 to be exact), JK 1.2.15 and IIS 5 
> (Win2k server).
> I'm running a single Tomcat instance, and it's on the same 
> server as IIS.
> 
> I was also having these messages, really thousands every day:
> 
> ---------------------------------------------
> [Thu Feb 02 08:21:08 2006] [warn]  jk_ajp_common.c (2138): 
> Unable to get the
> free endpoint for worker ajp13 from 10 slots
> [Thu Feb 02 08:21:08 2006] [info]  jk_ajp_common.c (2152): 
> can't find free
> endpoint
> ---------------------------------------------
> 
> Increasing the cachesize in worker.properties to 100 indeed 
> fixes these
> problems! Many tanx to Mladen Turk for his replies earlier in 
> this thread!
> I've been having this problem since september 2005, and 
> generated A LOT OF
> "page not found errors". These have now disappeared :-)
> 
> However, the JK logs still show a whole lot of (about 10.000 
> every day!!)
> these errors:
> 
> ---------------------------------------------
> [Wed Feb 08 13:03:49 2006] [error] jk_isapi_plugin.c (639): 
> WriteClient
> failed with 00002745
> [Wed Feb 08 13:03:49 2006] [info]  jk_ajp_common.c (1384): Connection
> aborted or network problems
> [Wed Feb 08 13:03:49 2006] [info]  jk_ajp_common.c (1731): 
> Receiving from
> tomcat failed, because of client error without recovery in send loop 0
> [Wed Feb 08 13:03:49 2006] [info]  jk_lb_worker.c (711): 
> unrecoverable error
> 400, request failed. Client failed in the middle of request, we can't
> recover to another instance.
> ---------------------------------------------
> 
> Here's my worker.properties file:
> 
> ---------------------------------------------
> ps=\
> workers.tomcat_home=C:\Tomcat5.5
> workers.java_home=C:\Java\jre5
> worker.list=ajp13,jkstatus
> 
> worker.ajp13w.type=ajp13
> worker.ajp13w.host=localhost
> worker.ajp13w.port=8009
> #note: Tomcat AJP maxThreads is currently at 125
> worker.ajp13w.cachesize=100
> worker.ajp13w.lbfactor=1
> worker.ajp13w.redirect=catch
> 
> worker.catch.type=ajp13
> worker.catch.host=localhost
> worker.catch.port=8009
> worker.catch.lbfactor=1
> worker.catch.disabled=true
> 
> worker.ajp13.type=lb
> worker.ajp13.balance_workers=ajp13w,catch
> 
> worker.jkstatus.type=status
> ---------------------------------------------
> 
> I'm not sure yet if these errors actually have any consequences for my
> site-visitors, since I only just fixed the "can't find free endpoint"
> problem. But I do know, those errors must be there for a reason...
> 
> Anyone?
> 
> Tanx a lot!
> Paul Hamer
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message