tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joey Geiger" <j...@staff.onmilwaukee.com>
Subject RE: Tomcat 5.5.15 Context Reloading issue
Date Wed, 15 Feb 2006 17:52:47 GMT
Well, I discovered the cause of the bug, and I can now stop it from
happening, but I'm unable to *fix* the problem. The top logging statement
works properly, while the commented one does not. 

The NullPointer on the date occurs because a date is not being sent to the
logger when the context is reloaded. The date is sent on a startup. Tomcat
can survive this error during reload. The other error
(NoClassDefFoundError:VectorWriter) is an issue with the line number being
sent to the logger, which causes the reload to completely fail. 

log4j.appender.ap.layout.ConversionPattern=%p %t %c - %m%n
#log4j.appender.ap.layout.ConversionPattern=%d{ABSOLUTE} %5p %c{1}:%L - %m%n


Log output:
Initial Load:
11:42:20,781 INFO
org.apache.catalina.core.ContainerBase.[Catalina].[hostname.com].[/] -
Loading Spring root WebApplicationContext

Reload:
INFO org.apache.catalina.core.ContainerBase.[Catalina].[hostname.com].[/] -
Loading Spring root WebApplicationContext

-----Original Message-----
From: Caldarale, Charles R [mailto:Chuck.Caldarale@unisys.com] 
Sent: Tuesday, February 07, 2006 9:15 AM
To: Tomcat Users List
Subject: RE: Tomcat 5.5.15 Context Reloading issue

> From: Joey Geiger [mailto:joey@staff.onmilwaukee.com] 
> Subject: Tomcat 5.5.15 Context Reloading issue
> 
> The host is configured as:
> 
> <Host name="application.com" appBase="C:\web\application" 
> unpackWARs="true" autoDeploy="true" xmlValidation="false"
> xmlNamespaceAware="false" reloadable="true">
> 
> <Context path="" docBase="" debug="1" reloadable="true">
> <Manager pathname="" />
> </Host>

An empty docBase path is rather odd.  The appBase parameter is supposed
to point to the directory under which one or more application
directories or war files are stored; docBase should specify the
directory or war for the given application.  Perhaps you should try
setting appBase to "C:\web" and docBase to "application".

> I've tried to add log4j 1.2.9 to both the common/lib and 
> server/lib with no success.

Not at the same time, I hope.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message