tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Question about compiling JK1.2.15
Date Tue, 03 Jan 2006 02:36:57 GMT
It looks like you did:
  ./configure --with-apache=/path/to/httpd/source

instead of:
  ./configure --with-apxs=/path/to/httpd/dist/bin/apxs

The first builds mod_jk for static linking with Httpd, the second builds 
mod_jk.so.  The second also correctly resolves the apr and apr-util includes 
automagically.

Of course, with 2.2.x, you could always simply use mod_proxy_ajp and save 
yourself a lot of work building mod_jk ;-).

"Bob Smith" <bob@netprt.com> wrote in message 
news:37150.192.168.100.4.1136254624.squirrel@www.netprt.com...
> Hi Gurus,
>
> I'm trying to install JK 1.2.15 on Red Hat 9, for Apache 2.2.x and Tomcat
> 5.5.
> I ran configure and had to solve some dependency issues (apr and apr-util
> includes), and finally got it to compile.  However, it did not compile
> mod_jk.so file, but the following:
>
> mod_jk.o
> mod_jk.lo
> lib_jk.la
>
> It's been a while since I played with C, so can anyone give me pointers
> on creating mod_jk.so?
>
> Thanks,
>
> -Bob 




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message