tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Piterman <rpiter...@gmx.net>
Subject solved (607-patch): encoding problem with tomcat
Date Mon, 02 Jan 2006 17:55:41 GMT
607-patch seems to work this out.

Ron Piterman wrote:
> Mark Thomas wrote:
> 
>> Can you provide the smallest possible servlet/JSP that doesn't work?
>> At a guess running in debug mode is fixing/working around some other
>> issue that is the root cause of the problem.
>>
>> Mark
> 
> 
> I am using tapestry, so I can not really deliver anyhting else than a 
> tapestry page / appliction configuration.
> 
> I Posted this message also on the tapestry user list, and had no 
> response yet which could get me going, but I will double check my 
> tapestry configuration parameters and see.
> 
> Cheers,
> Ron
> 
> PS - If you want i can send a small tapestry application which 
> demonstrates the prob, with or without tapestry jars.
> 
> 
>>
>> Ron Piterman wrote:
>>
>>> now also when both are using the symlink at /home/ron/tomcat, running
>>> tomcat in normal mode (without debugging) gives me wrong encoding...
>>> ?
>>>
>>> Ron Piterman wrote:
>>>
>>>
>>>> Here are both commands, as listed by ps (i broke them to make reading
>>>> easier):
>>>>
>>>>
>>>> >> first the normal tomcat:
>>>> >>
>>>>
>>>> /usr/java/jre/bin/java
>>>>
>>>> -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
>>>> -Djava.util.logging.config.file=/usr/java/tomcat/conf/logging.properties

>>>>
>>>> -Djava.endorsed.dirs=/usr/java/tomcat/common/endorsed
>>>> -classpath
>>>> :/usr/java/tomcat/bin/bootstrap.jar
>>>> :/usr/java/tomcat/bin/commons-logging-api.jar
>>>> -Dcatalina.base=/usr/java/tomcat
>>>> -Dcatalina.home=/usr/java/tomcat
>>>> -Djava.io.tmpdir=/usr/java/tomcat/temp
>>>> org.apache.catalina.startup.Bootstrap
>>>> start
>>>>
>>>> >> then in debug mode:
>>>> >>
>>>>
>>>> /usr/java/jre/bin/java
>>>>
>>>> -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
>>>> -Djava.util.logging.config.file=/home/ron/tomcat/conf/logging.properties

>>>>
>>>> -Xdebug
>>>> -Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n
>>>> -Djava.endorsed.dirs=/home/ron/tomcat/common/endorsed
>>>> -classpath
>>>> :/home/ron/tomcat/bin/bootstrap.jar
>>>> :/home/ron/tomcat/bin/commons-logging-api.jar
>>>> -Dcatalina.base=/home/ron/tomcat
>>>> -Dcatalina.home=/home/ron/tomcat
>>>> -Djava.io.tmpdir=/home/ron/tomcat/temp
>>>> org.apache.catalina.startup.Bootstrap start
>>>>
>>>> ---
>>>>
>>>> Now the only difference seems to be in the catalina.home and
>>>> catalina.base parameters -
>>>>
>>>> /home/ron/tomcat is a symlink to /usr/java/tomcat/
>>>>
>>>> why should that make a difference ?
>>>>
>>>> will try to change that and see what happens...
>>>> (will be back after the commercials :) )
>>>>
>>>> Cheers,
>>>> Ron
>>>>
>>>>
>>>> Ron Piterman wrote:
>>>>
>>>>
>>>>> Hi all,
>>>>> I have this strange encoding problem with tomcat 5.5.12 serving
>>>>> tapestry pages:
>>>>>
>>>>> when I start tomcat using the startup.sh script, my tapestry pages are
>>>>> served with something wrong along the encoding pipeline, so some
>>>>> "special"  characters like ä or ß are encoded wrong.
>>>>>
>>>>> when I start tomcat using the catalina.sh in debug mode, everything is
>>>>> fine -
>>>>>
>>>>> does someone have a clue of what or where the problem might be?
>>>>>
>>>>> Cheers,
>>>>> Ron
>>>
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message