tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aparna_Maddire...@Countrywide.Com
Subject Re: [OT] 64Bit Java doesn't honour Xmx,Xms settings?
Date Tue, 17 Jan 2006 17:19:15 GMT
Hi,

I am setting the PermGen with JvmX option (JvmX 256mb). 

Thank you,
Aparna




"Peter Lin" <woolfel@gmail.com> 
01/17/2006 09:15 AM
Please respond to
"Tomcat Users List" <users@tomcat.apache.org>


To
"Tomcat Users List" <users@tomcat.apache.org>
cc

Subject
Re: [OT] 64Bit Java doesn't honour Xmx,Xms settings?






permgen isn't affected by the normal

-Xms -Xmx

you have to explicitly set the permGen using the proper setting. I forget
the exact syntax at the moment, but it should be archived on the mailing
list.

peter


On 1/17/06, Aparna_Maddireddy@countrywide.com <
Aparna_Maddireddy@countrywide.com> wrote:
>
> Hi,
>
>
> Did you check if the new parameter (Xms, Xmx)values are registered for
> your service ? (I am not sure how it works on Linux ).
> Here is a similar issue but on Windows platform.
> I am working with 64 bit java on Windows 2003 and 64-bit AMD Opteron
> processor with 16 GB RAM.
> I am getting OOME due to PermGen space. I set the following parameteres 
in
> my service.bat file :
> JvmXms = 6g  JvmXmx = 6g JvmX = 256mb.
> The problem is when I start the tomcat service it is not taking these
> values.  I checked the windows registry
> and these parameter values are not inserted.  Do you have any idea like
> what might be the problem and
> how to fix these issue ? Any help would be greatly appereciated.
>
> (Note: The same application on 32-bit works just fine .)
>
> Thank you,
> Aparna.
>
>
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message