tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Sabroff <mike.sabr...@cygnusb2b.com>
Subject Re: https difficulties w/ Tomcat5
Date Wed, 25 Jan 2006 17:50:11 GMT
it works fine for me in 5.5.12  I haven't tried 5.5.15....isn't that 
still in beta status??

TonyCoco@comcast.net wrote:
> I had the same problem with Tomcat 5.5.12. Finally someone told me to check the Tomcat
5.5\bin directory for a file called tcnative-1.dll (or something like that, I don't remember
exactly). After I deleted that file, my SSL connections worked fine. 
>
>
>  -------------- Original message ----------------------
> From: "Stevie G. Messervey" <nuke48386@yahoo.com>
>   
>> Hello,
>>      Please let me preface that I have actually tried
>> to run down various
>> threads,tutorials,FAQS, and the Tomcat docs (both
>> shipped & online).
>>
>> dist: Crux Evolution 2.0.x kernel: 2.6.8.1 gcc:3.3.4
>> java:jdk1.5.0_06
>> kde:3.3(incl/konqueror) firefox:1.5 Tomcat:5.5.15
>> (binary tar.gz)
>> APR:1.2.2
>>
>> Basically, I cannot get the SSL connector to work. I
>> uncomment the 
>> appropriate entry in server.xml, and when I try to
>> access 
>> https://localhost:8443,the session times out. 
>> Oddly (to me), accessing via http://localhost:8080
>> works.
>>
>> I do have the keystore properly configured, as I
>> recently installed 4.1.31
>> to test it. Tomcat4.1.31 w/ https works flawlessly.
>>
>> I chased this thing round and round- I downloaded
>> firefox, thinking maybe 
>> it was a browser issue, as I built KDE myself(i.e.
>> it's not the bundle from the distro). Same issue. I
>> don't really suspect gcc or associated
>> problems,as jsvc and libtcnative both compiled (and
>> installed, for
>> libtcnative) w/o complaint.
>>
>> I have even tried copying a modified <Connector> from
>> 4.1.31, which 
>> (unmodified) works under 4.1.31 . 
>> I have tried explicitly setting the address, i.e.
>> address="127.0.0.1"; no
>> luck. I created some scripts to monitor the tomcat
>> sessions, the most
>> useful fragment being 'neststat -p | grep localhost:',
>> which, during my
>> tests, shows tomcat talking to itself, from which I
>> can conclude that the
>> sessions are being started.
>>
>> The only thing I haven't tried is building from
>> source.
>>
>> In short, has anyone else been able to:
>> * get https working, 'out of the box', from the 5.5.15
>> binary .tar.gz?
>> * ditto above, with Crux? Crux-Evolution?
>>
>>
>> Thank you for your time and interest,
>>  Tarkin
>>
>> __________________________________________________
>> Do You Yahoo!?
>> Tired of spam?  Yahoo! Mail has the best spam protection around 
>> http://mail.yahoo.com 
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>     
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>   

-- 
Mike Sabroff
Web Services
Developer
mike.sabroff@cygnusb2b.com
920-568-8379


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message