tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Mazza <grm7...@verizon.net>
Subject Re: blank admin
Date Mon, 23 Jan 2006 21:16:35 GMT
kalin mintchev wrote:
> 
> tomcat-users.xml:
> 
>>><?xml version='1.0' encoding='utf-8'?>
>>><tomcat-users>
>>>  <role rolename="manager"/>
>>>  <role rolename="admin"/>
>>>  <user username="manager" password="very-secret" roles="manager"/>
>>><user username="admin" password="bigger-secret"
>>>roles="admin,manager"/>
>>></tomcat-users>
>>>this is probably normal but i would like to mention that even if i change
>>>the order if the elements in the tomcat-users and put admin first after
>>>restarting the server they get switched back in this order...
>>
>>I sense tomcat-users.xml may not be your problem--it seems something
>>URL-related to me.
> 
> 
>  like how?
> 

It seems what you have in your tomcat-users.xml file is OK, although I 
would use try a different username instead of "admin" because it matches 
the role name.  (I don't know if that is commonly done for Tomcat, however.)

I use TC 5.5, where the Admin app is a separate download from the main 
distribution.  FWIW, it works fine for me on 5.5, using a tomcat-users 
file very similar to yours.

Sorry I can't help you much here I guess.

Glen


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message