tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bjørge Solli <bjorge.so...@nersc.no>
Subject error 500
Date Mon, 02 Jan 2006 12:55:18 GMT
Hi

I am using a servlet called Live Access Server(las)[1], and get an error 
that none on the las mailing list seems to know the answer to. Maybe 
anyone here understands it:

When I open http://testserver.com/las/servlets/dataset I get a 500 error:

#########

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented 
it from fulfilling this request.

exception

java.lang.ClassCastException: java.lang.NoClassDefFoundError
     gov.noaa.pmel.tmap.ExceptionFilter.doFilter(ExceptionFilter.java:39)

note The full stack trace of the root cause is available in the Apache 
Tomcat/5.0 logs.
Apache Tomcat/5.0

#########

My /usr/share/tomcat5/logs/catalina.out says:

#########

javax.servlet.ServletException: Filter execution threw an exception
         at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:226)
         at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
         at 
gov.noaa.pmel.tmap.ExceptionFilter.doFilter(ExceptionFilter.java:24)
         at 
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
         at 
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
         at 
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
         at 
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
         at 
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
         at 
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
         at 
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
         at 
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
         at 
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
         at 
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
         at 
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
         at 
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
         at 
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
         at 
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
         at 
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
         at 
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
         at 
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
         at 
org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
         at 
org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
         at 
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:799)
         at 
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:705)
         at 
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:577)
         at 
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
         at java.lang.Thread.run(Thread.java:595)

#########

Does anyone know what causes this error? It seems to me there is 
something wrong with the CLASSPATH (maybe caused by me using my existing 
tomcat instead of the bundled one?) I don't know how to set the 
classpath for servlets in tomcat5 but I did try this:
/usr/share/tomcat5/server/classes$ ln -s \ 
/usr/share/tomcat5/webapps/las/WEB-INF/classes/gov

But no sigar (yes, I restarted tomcat).

I have tried to use the tomcat bundled with las and the standard one 
with Fedora Core 4. I always get the same error. Funny thing is that 
with the same javainstall, and the same bundled tomcat it worked at 
first try on FC3.

Any help appreciated.

[1] http://ferret.wrc.noaa.gov/Ferret/LAS/Downloads/

-- 
Bjørge Solli - Office:+47 55205847 cellph.:+47 91614343
Nansen Environmental and Remote Sensing Center - Bergen, Norway
http://www.nersc.no Reception: +47 55205800
Dept.: Mohn-Sverdrup Center for Global Ocean Studies
        and Operational Oceanography

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message