tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: tomcat doesn't load file on another pc
Date Sun, 01 Jan 2006 12:31:59 GMT
Anne Milbert wrote:
> Hi Mark,
> I run tomcat as the localhost on my computer. If I try
> to connect (with the IE for example) tomcat from another
> pc on the network it works fine.
> 
> I can connect to my application from another pc and 
> everything except of one thing works.
> 
> One main part of my webapplication are several XForms which 
> are located in a folder of my webapplication. Every time I 
> try to open/load one of the XForms I see a blank page
> instead of it. It seems that tomcat doesn't get the GET-Parametres 
> via the URL which the application needs to "decide" whether it 
> should load a XForms or the default page.

It sounds like an application problem. I suggest using the
RequestDumperValve (see
http://tomcat.apache.org/tomcat-5.5-doc/config/valve.html) to check
what is being passed to Tomcat by the clients. You should be able to
compare the logs for a local IE client and a remote IE client.

Another tool that might be useful is ieHttpHeaders which lets you see
what headers Tomcat is sending to the client.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message