tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Monica Wu" <Monica...@XenoPort.com>
Subject RE: Tomcat upgrade: 3.3.1 --> 5.0.28, hang up after running 1 or 2 days
Date Tue, 24 Jan 2006 19:11:22 GMT
Thank you for your attention, Glen!

These 2 (good and buggy) production tomcat servers run different web applications on different
physical machines. Their hardware and operation systems including Windows service packs are
same. Tomcat configuration is very similar. The good tomcat server was brand new (new installed
operating system, new web application) and started Java 5.0 + tomcat 5.0 at the very beginning.
The buggy one started with Java1.3 + Tomcat 3.3.1 and had ran smoothly about 4 years. 

Regarding the web application on the buggy tomcat 5.0 server. The source code remain the same
before and after the tomcat upgrade. The only change is to use the new java 1.5 compiler with
option "-souce 1.4". Compiling is not a problem. Starting the buggy tomcat 5.0 is not a problem.
The only problem is hangup after some user access.

All possible changes were minimized during tomcat upgrade.

The buggy tomcat server was rolled back to Java 1.3 + tomcat 3.3.1 again last Friday. This
rollback did not fix the problem. Yesterday (last Monday) I removed Java 1.5 + Tomcat 5.0
completely. JDK 1.3 + J2EE 1.3 were re-installed. At this point, everything was rolled back
to the state before tomcat upgrade. 

This buggy tomcat server has run okay by far (< 24 hours), but is too early to say it is
fixed. If it can behave until the end of this week, I may dare to say it is fixed and the
problem is caused by the upgrade. Maybe the co-existence of Java 1.3 and 1.5. Maybe co-existence
of Tomcat 3.3 and 5.0. Maybe ...

- Monica


-----Original Message-----
From: Glen Mazza [mailto:grm7790@verizon.net]
Sent: Tuesday, January 24, 2006 10:47 AM
To: Tomcat Users List
Subject: Re: Tomcat upgrade: 3.3.1 --> 5.0.28, hang up after running 1
or 2 days


Monica Wu wrote:

> 
> First of all, upgraded to the version I have ever tested. Tomcat 5.0 has been running
well on my another production server about one year. At that installation time, Tomcat 5.0
was the latest. Moreover, having all productions share the same Java + tomcat versions is
one of my agendas to ease the development and maintenance.
> 

Oh!  Now I understand.  Thanks for the explanation and sorry I couldn't 
help you that much with your problem.  It is strange that Tomcat 5.0 has 
been running well for a year on one server but not the new one.  BTW, 
are you running different or the same web applications on the 
good-for-one-year 5.0 server and the buggy new 5.0 one?  I wonder if the 
source of the problem is with the applications that the buggy TC is 
running rather than TC itself.

Glen


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message