tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Schönhaber <mailing-tomcat-u...@schoenhaber.de>
Subject Re: Problems with Tomcat 5.5 build.xml
Date Wed, 25 Jan 2006 12:44:13 GMT
Andre Kammerl wrote:
> Sorry for the missing exact description of the Problem. The following
> output is given when I use ant (ver 1.6.5) on the build.xml file. Looks
> like the destinations of the links inside the build.xml do not exist.
>
> O:\Tomcat_5.5>ant
> Buildfile: build.xml
>
> check.source:
>
> get.source:
>
> checkout:
>         [echo] If the checkout fails, - todo -
>
> BUILD FAILED
> O:\Tomcat_5.5\build.xml:87: The following error occurred while executing
> this line:
> O:\Tomcat_5.5\build.xml:70: Execute failes: java.io.IOException:
> CreateProcess: svn checkout
> http://svn.apache.org/repos/asf//tomcat/current/tc5.5.x O:\Tomcat_5.5
> error=2
>
> Total time: 0 seconds
> O:\Tomcat_5.5>
>
> Hopefully somebody has an idea to solve my problem.

It seems that either you don't have Subversion installed or the svn.exe is not 
in %PATH%. The Tomcat sourcecode is managed in a Subversion repository and 
the ant build tries to check it out from there.
So you should install Subversion into a location where ant can find it.
Or, you could download the Tomcat source distribution and build that.

Regards
mks

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message