tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Bobak <>
Subject Static mod_jk buil & implementation issues(was mod_jk with httpd & tomcat)
Date Tue, 24 Jan 2006 16:21:57 GMT
I've found documentation for building mod_jk as a static module in apache here: (at the bottom of page).

On this step, I get this:

bash-2.05# ./buildconf
rebuilding srclib/apr/configure
buildconf: checking installation...
build/ autoconf: not found
buildconf: autoconf not found.
           You need autoconf version 2.13 or newer installed
           to build Apache from CVS.
./buildconf failed for apr

I cannot find autoconf version 2.13 anywhere.  Could someone please tell me where to get autoconf?

Assuming the build goes correctly, do I implement a static mod_jk any differently than a dynamic


Greg Bobak <> wrote: Hi,

Thansk for the reply.  I think I had found some documentation about rebuild Apache with mod_jk
bound.  I'll have to look again.  

I've been trying to rebuild mod_jk (to no avail) in  hopes that would work, but keep getting
this error: 

could not find /usr/local/apache2/bin/apxs
configure: error: You must specify a valid --with-apxs path

Of course it is the right path.


Mike Sabroff  wrote: I had the same problem a while back. I had to do some googling and find

the mod_jk source. Trying to compile it was problematic and I also got 
the unresolved errors I had to rebuild apache with jk as part of the 
build in order to get it to work.

I wish I could remember where I got the source and the instructions, but 
I am old and forget easily (actually age has nothing to do with 
it....always been like that)
I appologize, especially since I spent many hours trying this and that 
and I know what you are going through
I do remember, that the proceedure was different with apache 2.x than it 
was with 1.3x that I have installed.

Greg Bobak wrote:
> I am using Tomcat 5.0.28 BTW.
> G.
> Greg Bobak  wrote:  I am trying to get mod_jk to 
> work with apache 2.0.55 and get this error on the load module:
> Syntax error on line 276 of /usr/local/apache2/conf/httpd.conf:
> Cannot load /usr/local/apache2/modules/ into server: 
> /usr/local/apache2/bin/httpd: fatal: relocation error: file 
> /usr/local/apache2/modules/ symbol ap_null_cleanup: 
> referenced symbol not found
> I have looked everywhere, and have been advised to recompile apache, 
> which I have done successfully a few times.  This is how I have 
> recompiled:
> ./configure --prefix=/usr/local/apache2 --enable-mods-shared=all 
> --enable-ssl=shared --enable-ssl --with-ssl=/usr/local/ssl 
> --enable-proxy --enable-proxy-connect --enable-proxy-ftp 
> --enable-proxy-http --enable-so --enable-rule="SHARED_CORE"
> make
> make install
> I use "make clean" between attempts..Ihave tried withou the 
> "SHARED_CORE" and without the --enable-so because 
> --enable-mods-shared=all should cover that.  Still no luck.
> I am using Solaris 9.  Here is some diag info:
> root@anf-echttp1:/usr/local/apache2/bin # ldd -d  
> /usr/local/apache2/modules/
> =>     /usr/lib/
> =>    /usr/lib/
>         symbol not found: ap_server_root                
> (/usr/local/apache2/modules/
>         symbol not found: ap_null_cleanup               
> (/usr/local/apache2/modules/
>         symbol not found: dir_module            
> (/usr/local/apache2/modules/
>         /usr/platform/SUNW,Serverblade1/lib/
> root@anf-echttp1:/usr/local/apache2/bin # httpd -V
> Server version: Apache/2.0.55
> Server built:   Jan 23 2006 13:17:34
> Server's Module Magic Number: 20020903:11
> Architecture:   32-bit
> Server compiled with....
>  -D APACHE_MPM_DIR="server/mpm/prefork"
>  -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
>  -D HTTPD_ROOT="/usr/local/apache2"
>  -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
>  -D DEFAULT_PIDLOG="logs/"
>  -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
>  -D DEFAULT_LOCKFILE="logs/accept.lock"
>  -D DEFAULT_ERRORLOG="logs/error_log"
>  -D AP_TYPES_CONFIG_FILE="conf/mime.types"
>  -D SERVER_CONFIG_FILE="conf/httpd.conf"
> root@anf-echttp1:/usr/local/apache2/bin # httpd -v
> Server version: Apache/2.0.55
> Server built:   Jan 23 2006 13:17:34
> Please advise as to what info would be helpful in determining the root 
> cause.
> Thanks for your help,
> Greg
> ---------------------------------
>  What are the most popular cars?  Find out at Yahoo! Autos
> ---------------------------------
>  What are the most popular cars?  Find out at Yahoo! Autos

Mike Sabroff
Web Services Developer

To unsubscribe, e-mail:
For additional commands, e-mail:

Yahoo! Photos
 Got holiday prints? See all the ways to get quality prints in your hands ASAP.

 Yahoo! Autos. Looking for a sweet ride? Get pricing, reviews, & more on new and used
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message